You are here

TIME and DATE issue

8 posts / 0 new
Last post
Rishikesh Jha
Offline
Donator
Joined: 1 year
Last seen: 2 weeks
TIME and DATE issue

Hello admin,

I need help, I am getting EPG through tatasky.com.EK and my timezone is Asia/Calcutta (UTC +5:30).

I am getting channel output like this start="20200823153000 +0530" stop="20200823163000 +0530" but I need Date/Time +5:30 ahead of what I am getting in actual.

current getting like this = "20200823153000 +0530"
need like this = "20200823210000 +0530"

Thanks

mat8861
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 hour

run wg2mp will fix time to your local time

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

did u change the timezone in the ini because its set wrong,it should be timezone=UTC not Asia/Calcutta

Rishikesh Jha
Offline
Donator
Joined: 1 year
Last seen: 2 weeks

I used WG2MP, still same issue. After run WG2MP only difference is +0530 is replaced but date and time is still same as output.xml
Here I am attaching the Output.zip file which contains both output, you can compare both.

Thanks

Attachments: 
Rishikesh Jha
Offline
Donator
Joined: 1 year
Last seen: 2 weeks

yes already did this

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week

change the timezone setting in the ini to UTC and u wont need to use wg2mp.
this will change the timeoffset from +0530 to +0000.
when your epg software loads the epg data it will get your local timezone from your device which will be +0530(Asia/Calcutta).
it will then compare the timeoffset of the epg data(+0000) to you local timezone(+0530) and will add 5.5 hrs to all start/stop times in the epg so when you view it its appears correct in your local time.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 week
Rishikesh Jha wrote:

I used WG2MP, still same issue. After run WG2MP only difference is +0530 is replaced but date and time is still same as output.xml
Here I am attaching the Output.zip file which contains both output, you can compare both.
Thanks

the reason this did nothing is because the data is in the wrong timezone.ur using asia/calcutta.
when wg2mp runs its detects your local timezone(also asia/calcutta) so it thinks the data is already in your local timezone.

Rishikesh Jha
Offline
Donator
Joined: 1 year
Last seen: 2 weeks

I used xmltv_time_correct and set
channel time_error=5.5, because I need +0530,

It's Working !!!!

Thanks

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl