You are here

Object reference not set to an instance of an object.

9 posts / 0 new
Last post
Graburrz
Offline
Donator
Joined: 7 years
Last seen: 1 month
Object reference not set to an instance of an object.

I'm running V2.1.1_beta on Windows 7 and Windows 10 systems and am getting this error message for the Deutsche Welle channel taken from the horizon.tv.channels.xml in the latest siteini.pack when running WG to update my epgguide xml:

[  Info  ] Group (0) :
[  Info  ] update requested for - 5 - out of - 5 - channels for 7 day(s)
[  Debug ]
[  Info  ] (   1/5   ) HORIZON.TV -- chan. (xmltv_id=DW) -- mode Incremental
[  Debug ]    skipped : show that happened before 'today' @ 23/03/2018 22:30
[  Debug ]    skipped : show that happened before 'today' @ 23/03/2018 23:00
[  Debug ]    skipped : show that happened before 'today' @ 23/03/2018 23:02
[  Debug ]    skipped : show that happened before 'today' @ 23/03/2018 23:15
[  Debug ]    skipped : show that happened before 'today' @ 23/03/2018 23:30
[Error   ] Unable to update channel DW
[Critical] See log file for details
[Critical] Exception.Message: Object reference not set to an instance of an object.
[Critical] Exception.StackTrace:    at WGconsole.Program.UpdateChannel(String strIndex, ChannelToUpdate Chan, XmlTarget xTarget)
   at WGconsole.Program.ConsoleApplication(String[] args)
[  Info  ] Existing guide data restored!
[  Debug ]

I didn't get any error when I 1st ran the grab without an existing epgguide xml file.  It only pops up when running WG a 2nd time to update the file.  This same error was reported a year ago, and was apparently caused by an issue with version 2.0.2.  

http://www.webgrabplus.com/content/object-reference-not-set-instance-object

So I rolled my v2.1.1 beta back to v2.1, and re-ran the test.  But got the same error message. Could this be a problem with the horizon.tv.ini?

Graburrz
Offline
Donator
Joined: 7 years
Last seen: 1 month

Yes... I start each new test from scratch with no guide xml and only about 5 - 6 channels in a test config @Blackbear199.  Then I run it again after 30 - 60 minutes to update the guide xml created in the 1st grab.  I'll track down v2.1.5, do a couple tests and post back.

 

Graburrz
Offline
Donator
Joined: 7 years
Last seen: 1 month

Both rolling back to v2.1 on my Win7 system, and upgrading to v2.1.5 on my Win10 system resulted in not getting that error running an update grab.  You must have been right on my having used an existing test source xml when I ran tests with v2.1 the other day Blackbear. I ran a fresh grab again today with no existing source xml and a small config in v2.1, then ran it again.  This time that error didn't show up in the 2nd grab.

I did get a warning though about horizon.tv.ini being incompatible, and that I should update v2.1 to v2.1.1 which is where I was the other day when I started this adventure:

[  Info  ] found: C:\Users\[user]\AppData\Local\WebGrab+Plus\siteini.pack\International\horizon.tv.ini -- Revision 06
[Warning ] Incompatible version of C:\Users\[user]\AppData\Local\WebGrab+Plus\siteini.pack\International\horizon.tv.ini
[Warning ] SW  V2.1 should be >= SiteIni V2.1.1:
[Warning ] Upgrade your WebGrab+Plus version to V2.1.1 or higher!! @http://www.webgrabplus.com/download

I compared the horizon.tv.ini files in the past 3 siteini.pack 'International' folders and found they all match.  And the warning didn't seem to effect the final grabbed xml.

But then I ran a grab in v2.1 with my full config reading my last good full source xml, and the error popped up again.  So I re-ran the full grab again without any source xml to read.  When I ran an update on the xml that produced, this "Object reference not set.." didn't pop up again.  I don't know enough about WG to understand why that was, but happy days! smiley

That was on my Win7 system.  I ran a grab on the same config with v2.1.5 installed on my Win10 system the same way I had in Win7, with no existing source xml, and then running a 2nd update grab.  This is probably something you guys understand as part of how the 2.5 beta works, but I thought I'd point it out.  Instead of just displaying rows of '.=same' dots indicating no changes for the existing programs, it would change a (n) at the end of the  <desc lang=""> tag for every existing program in the final source xml to either (c) or just remove it.  

[  Info  ] (  17/225 ) HORIZON.TV -- chan. (xmltv_id=DW) -- mode Incremental
[  Debug ]    skipped : show that happened before 'today' @ 24/03/2018 22:30
[  Debug ]    skipped : show that happened before 'today' @ 24/03/2018 23:00
[  Debug ]    skipped : show that happened before 'today' @ 24/03/2018 23:15
[  Debug ]    skipped : show that happened before 'today' @ 24/03/2018 23:30
[  Info  ]    epg correction :
[  Info  ]  CHANGED show corrected,
[  Info  ]       show with ---- start = 25/03/2018 00:00:00 stop = 25/03/2018 00:15:00 title = WG.common.xmltv.Title
[  Info  ]       Replaces ----- start = 25/03/2018 00:00:00 stop = 25/03/2018 00:15:00 title = DW News
[  Info  ]    epg correction :
[  Info  ]  CHANGED show corrected,
[  Info  ]       show with ---- start = 25/03/2018 00:15:00 stop = 25/03/2018 00:30:00 title = WG.common.xmltv.Title
[  Info  ]       Replaces ----- start = 25/03/2018 00:15:00 stop = 25/03/2018 00:30:00 title = The Bundesliga - Your Team, your League, your Show

So at least both v2.1 and v2.1.5 aren't skipping program updates completely and restoring the existing guide data. Now just to choose which version to run on both systems.

Graburrz
Offline
Donator
Joined: 7 years
Last seen: 1 month

Thanks for that Blackbear.  I'll go ahead and update WG on my Win7 system to v2.1.5.  Good learning expreince all this. smiley

drogica
Offline
Donator
Joined: 1 year
Last seen: 2 weeks

it worked for a long time, but it stops 1 week ago with this error:

[ ]
[ ] WebGrab+Plus/w MDB & REX Postprocess -- version V3.3.0.0
[ ]
[ ] Jan van Straaten
[ ] Francis De Paemeleere
[ ]
[ ] thanks to Paul Weterings, Mat8861, Blackbear199 and all the contributing users
[ ] --------------------------------------------------------------------------------
[ ]
[ ] Job started at 08/04/2023 03:03:55
[ Debug ]
[ Debug ] Running on: Unix 5.15.102.1
[ Debug ] Environment: 4.0.30319.42000
[ Debug ] Mono version: 6.8.0.105 (Debian 6.8.0.105+dfsg-3.2 Tue Jun 29 21:01:01 UTC 2021)
[ Debug ]
[ Debug ] Loading timezone data
[ Debug ] Embedded timezones source: timezone.timezonesdata.txt
[ Debug ] Reading config file: /root/.wg++/./WebGrab++.config.xml
[ Info ] Checking License ..
[ Info ] For License request/update data, see WGLicense.log.txt
[ ] Job finished at 08/04/2023 03:03:55 done in 0s
[Critical]
Object reference not set to an instance of an object
[Critical]
at  . ..ctor (System.String ) [0x0138d] in <86e27bf513e345f3b815dd4f534eb13f>:0
at  .—.  (System.String[] ) [0x0034b] in <86e27bf513e345f3b815dd4f534eb13f>:0
[Critical] Unhandled Exception
[Critical] For detailed info, see log file /root/.wg++/./WebGrab++.log.txt
[Critical] Execution stopped

Proxmos runs in a debian container, nothing has changed since the last operation

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 6 days

try updating ssl certificates
sudo update-ca-certificates

drogica
Offline
Donator
Joined: 1 year
Last seen: 2 weeks

Unfortunately, it didn't help. I tried deleting the .lic file using Google DNS, but not everything I found on the forum is working.

I created a new Proxmox Ubuntu container, installed it, and this is what I got:

[ ] WebGrab++ license request and update log
[ ] 2023/04/08 10:24
[ ]
[ Info ] License request/update
[ Info ] Username 'xxx'
[Error ] Hardware mismatch, the maximum of 2 computer hardware_id's is already registered
[ ]
[Warning ] The program cannot run right now on this computer,
[Warning ] but it's hardware_id will be ADDED and ready to use after 2023/04/08 11:24 ,
[Warning ] and it will REPLACE one of the previously registered computers as soon as you run on the ONE YOU WANT TO KEEP !!
[ Info ] License status : 'False'
[ Info ] Next update, first run after : 2023/04/09 10:24
[Warning ] License has expired !
[ Info ] The program will run with performance settings : 'default'
[ Info ] License check .. done
[ ]
[ ] Actual settings of the various licenses (may change from time to time) :
[ ]
[ ] default donator_license donator registered_user un_registrd_user developer
[ ] channels/ini 20 250 50 30 20 1000
[ ] channels total 20 250 50 30 20 1000
[ ] siteinis 2 15 10 3 2 100
[ ] decryption keys without userkey enabled enabled enabled without userkey enabled
[ ] decryption mode legacy (V2) new (V3) & (V2) legacy (V2) legacy (V2) legacy (V2) new (V3) & (V2)
[ ] index only yes no no no yes no
[ ] postprocess MDB disabled enabled enabled disabled disabled enabled
[ ] postprocess REX disabled enabled enabled enabled disabled enabled
[ ] debug False False False False False True
[ ] show details * ttd full full ttsd ttd full
[ ] update mode force all all light force all
[ ] channel delay 4 secs 0 secs 0 secs 2 secs 4 secs 0 secs
[ ] index delay 4 secs 0 secs 0 secs 4 secs 4 secs 0 secs
[ ] show delay 2 secs 0 secs 0 secs 1 secs 2 secs 0 secs
[ ]
[ ] * showdetails : 'tt = times & title, 's' = subtitle, 'd' = description
[ ]
[ ] license update interval time : 168 hours

Previously, I only activated the license once, as far as I can remember. I replaced the other non-functioning system's .lic file with the generated wglocal.lic file, and now it works.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 6 days

do a force hardware id update.
use h for hardware force update,the same as you would do f for force license update.

timothyferriss
Offline
Joined: 5 months
Last seen: 5 months
Blackbear199 wrote:

do a force hardware id update.
use h for hardware force update,the same as you would do f for force retro bowl license update.

WebGrab+ often has a debug or verbose mode that provides more detailed information about the process. Enable debug mode if available to get more insights into where the error might be occurring.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl