You are here

Not able to use elmundo.es Rev 12

7 posts / 0 new
Last post
nickiman
Offline
nickiman's picture
Donator
Joined: 4 years
Last seen: 2 hours
Not able to use elmundo.es Rev 12

Hi all,

Long time since my latest post here...

I had some spare time to install the new Beta 2.1.11 and try the new site ini files...

I´ve started with elmundo.es Rev 12 obtained from Europe´s section in SiteIni.Pack subforum.

I´ve added the decription key information line in my WebGrab++config.xml file according withe the information posted.

But I get this error:

[ ]
[ ] WebGrab+Plus/w MDB & REX Postprocess -- version V2.1
[ ]
[ ] Jan van Straaten
[ ] Francis De Paemeleere
[ ]
[ ] thanks to Paul Weterings and all the contributing users
[ ] --------------------------------------------------------------------------------
[ ]
[ ] Job started at 07/11/2019 14:01:12
[ Debug ]
[ Debug ] Running on: Unix 4.14.24.0
[ Debug ] Environment: 4.0.30319.42000
[ Debug ] Mono version: 5.20.1.19 (tarball Tue May 28 11:37:22 CEST 2019)
[ Debug ]
[ Debug ] Loading timezone data
[ Debug ] Embedded timezones source: WGconsole.WG.Common.timezonesdata.txt
[ Debug ] Reading config file: /share/CACHEDEV1_DATA/.qpkg/WebGrabPlus/elmundo/WebGrab++.config.xml
[ ] Job finished at 07/11/2019 14:01:13 done in 0s
[Critical] Config syntax exception:
[Critical] file: /share/CACHEDEV1_DATA/.qpkg/WebGrabPlus/elmundo/WebGrab++.config.xml
[Critical] message:
[Error ] WG.Common.InvalidConfigException: [Error ] Settings element contains invalid sub-element "decryptkey"
at WGconsole.ConfigGroup..ctor (WGconsole.ConfigGroupSettings parent, System.Xml.XmlNode rawCfg) [0x001b8] in :0
at WGconsole.Config..ctor (System.String ConfigurationFilePath) [0x00711] in :0
[Critical] For detailed info, see log file /share/CACHEDEV1_DATA/.qpkg/WebGrabPlus/elmundo/WebGrab++.log.txt
[Critical] Execution stopped

I´ve reviewed the decription key and seems to be OK. So, don´t know where could be the problem...

Keep waiting your comments.

Thanks a lot!

nickiman
Offline
nickiman's picture
Donator
Joined: 4 years
Last seen: 2 hours

Ok, I´ve noted that the .xml file with the guide is correctly generated despite the error that I post before.

So, everything is OK :-)

In fact, I´ve noted that the guide file is generated instantly... WoW, really impressed.

Best regards.

mat8861
Offline
WG++ Team memberDonator
Joined: 4 years
Last seen: 8 hours

Glad you find yourself the solution and it works . As you could notice the error is given by an old version of wg++ (2.1) as the decryption is introduced from wg++2.1.9 or above , as a consequence the config sub-element (userkey)is not recognized by the old version and a warning is issued.

nickiman
Offline
nickiman's picture
Donator
Joined: 4 years
Last seen: 2 hours
mat8861 wrote:

Glad you find yourself the solution and it works . As you could notice the error is given by an old version of wg++ (2.1) as the decryption is introduced from wg++2.1.9 or above , as a consequence the config sub-element (userkey)is not recognized by the old version and a warning is issued.

Understood Mat, Thanks.

I´m going to give a try to the latest Beta 2.1.11 just to have the log the most clean possible :-)

nickiman
Offline
nickiman's picture
Donator
Joined: 4 years
Last seen: 2 hours

Ummm... Not having luck with this:

If I use the Beta 2.1.11 I get this error:


Unhandled Exception:
System.TypeLoadException: Could not load type of field 'WG.Common.InvalidSyntaxException:3' (3) due to: Could not load file or assembly 'logger, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type of field 'WG.Common.InvalidSyntaxException:3' (3) due to: Could not load file or assembly 'logger, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

With the above error EPG guide file is not generated.

However, If I use version Beta 2.1.9 I get the same previous error written in my first post but at least EPG guide file is correctly generated.

Also, I´m having problems with the siteini movistarplus.es which, even running it with 2.1.9 like elmundo.es, the EPG guide file is not generated giving me this error:


[ ]
[ ] WebGrab+Plus/w MDB & REX Postprocess -- version V2.1
[ ]
[ ] Jan van Straaten
[ ] Francis De Paemeleere
[ ]
[ ] thanks to Paul Weterings and all the contributing users
[ ] --------------------------------------------------------------------------------
[ ]
[ ] Job started at 09/11/2019 14:11:07
[ Debug ]
[ Debug ] Running on: Unix 4.14.24.0
[ Debug ] Environment: 4.0.30319.42000
[ Debug ] Mono version: 5.20.1.19 (tarball Tue May 28 11:37:22 CEST 2019)
[ Debug ]
[ Debug ] Loading timezone data
[ Debug ] Embedded timezones source: WGconsole.WG.Common.timezonesdata.txt
[ Debug ] Reading config file: /share/CACHEDEV1_DATA/.qpkg/WebGrabPlus/movistar/WebGrab++.config.xml
[ ] Job finished at 09/11/2019 14:11:08 done in 0s
[Critical] Config syntax exception:
[Critical] file: /share/CACHEDEV1_DATA/.qpkg/WebGrabPlus/movistar/WebGrab++.config.xml
[Critical] message:
[Error ] WG.Common.InvalidConfigException: [Error ] Settings element contains invalid sub-element "decryptkey"
at WGconsole.ConfigGroup..ctor (WGconsole.ConfigGroupSettings parent, System.Xml.XmlNode rawCfg) [0x001b8] in <274ad6f9740e441a95b86a1d1148edca>:0
at WGconsole.Config..ctor (System.String ConfigurationFilePath) [0x00711] in <274ad6f9740e441a95b86a1d1148edca>:0
[Critical] For detailed info, see log file /share/CACHEDEV1_DATA/.qpkg/WebGrabPlus/movistar/WebGrab++.log.txt
[Critical] Execution stopped

Keep waiting your comments. Thanks a lot.

mat8861
Offline
WG++ Team memberDonator
Joined: 4 years
Last seen: 8 hours

you are using wrong version should be:
WebGrab+Plus/w MDB & REX Postprocess -- version V2.1.11

nickiman
Offline
nickiman's picture
Donator
Joined: 4 years
Last seen: 2 hours
mat8861 wrote:

you are using wrong version should be:
WebGrab+Plus/w MDB & REX Postprocess -- version V2.1.11

Yes, now it works.

Probably I was crossing WG++ executables since I was mixing with the old ones the previous time I tried.

Thanks mat

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl