You are here

How can I get version 3.2.7?

5 posts / 0 new
Last post
RTDHTPC
Offline
Donator
Joined: 4 years
Last seen: 2 weeks
How can I get version 3.2.7?

Hi My system is running strangely.
I tried to update to V5.1 but this did not work (probably because I did not load .Net7 )
Reverting back to the last version (for me 3.2)
Everything seemed to work, but after updating the site.ini there appears to be a mismatch and I have the following errors.

1) licence check fails 2 out of 3 times, then decides to work anyway with donator licence.
2) EPG data returns error that site ini is incompatible, then works more or less.
Attached log files.

If possible i would like to install 3.2.7 and get a stable system then at a later date update to V5.1

I have 6 different config files which are called up at different times so as not to overload the backend.

Could you help?

Attachments: 
Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 2 hours

as you know there are improvements and fixes(hopefully) with each webgrab release.
if you edit a ini and look near the top in the header section you will see

* @MinSWversion: [version_number]

personally when i create or update a ini i put the webgrab version i used.
this tells me everything worked in the ini correctly with this version.
when users post something isnt working correctly and upload their log the first thing i look at is the webgrab version they are using.

to make the incompatible warning go away u could change this version number to the version you are using or any version number lower than what your using.
the actual version number doesnt have to exist and webgrab just compares the version number your running to the version number in the ini.

i dont recommend this as there may have been something fixed in the version number in the ini thats broken in the lower version number your using.

you can download older versions numbers from the downloads page.

Downloads ==> Other Downloads
its under the Windows and Linux tabs in the bottom right.
it take you to this page.

http://webgrabplus.com/download/sw

when you select a version it takes you back to the Windows/Linux tabs and you can download it.

if you going to use V3.x use V3.3
its the latest and last mono version.
V3.x versions are no longer being updated as it uses netframework which is end of life and no longer updated.
(V5.x uses dotnet as you pointed out already)
your going to have to upgrade to V5.x eventually so if i was you i would get it over with now.
more and more ini will need fixes and updates only V5.x will have.

RTDHTPC
Offline
Donator
Joined: 4 years
Last seen: 2 weeks

Thanks I will try this. The intention is to move to V5.x but to satisfy she who must be obeyed I need a "Quick Fix" till I have time to sit down and do it properly. Fantastic work by the way, this has worked so well till the site I was grabbing from changed.

RTDHTPC
Offline
Donator
Joined: 4 years
Last seen: 2 weeks

Thanks for your help. Everything working properly now. No problem with licence or incompatible files. next week V5.1!

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 2 hours

stay with V5.0.1
i ran into a bug a few days ago that affects all versions higher than that right up to V5.1.3
it only affects some ini's as it only happens under specific conditions.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl