You are here

Zap2it ini update?

8 posts / 0 new
Last post
jhr1948
Offline
Donator
Joined: 1 year
Last seen: 1 day
Zap2it ini update?

Hi all, i've always been a fan of zap2it (more than tvguide.com). The zap2it ini is extremely old and no longer works. Just wondering if someone could get help with an update.

jhr1948
Offline
Donator
Joined: 1 year
Last seen: 1 day

Any able to help? I like more details than TVPassport and tvtv.us I currently use TVGuide.com because I like the extra details, but I've posted a few times that it is starting to become unusuable (somedays).

I don't mind if it takes longer to grab using Zap2it (or TVGuide), but right now TVGuide is insanely slow right now. Talking 20 minutes and still on the same channel.

Anyway, don't know if Zap2it would be better.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 hour

its no faster than tvguide,maybe slower...
btw,check ur WGLisence.log.txt and see if you have donator status.
there seems to be a few posts lately about this,if ur reduced to anything other than donator then webgrab uses delays which slows down grabbing considerably.

jhr1948
Offline
Donator
Joined: 1 year
Last seen: 1 day
Blackbear199 wrote:

its no faster than tvguide,maybe slower...
btw,check ur WGLisence.log.txt and see if you have donator status.
there seems to be a few posts lately about this,if ur reduced to anything other than donator then webgrab uses delays which slows down grabbing considerably.

 
Hey Blackbear199, TVGuide.com speeds are fine normally, but i keep running into an issue where the speed gets abnormally slow. I'm getting the feeling its Linux related, because i grab from TVGuide.com on my Windows 10 laptop with no issues, even when my Linux server is having issues grabbing from TVGuide. My license shows correct: 'donator_license'
 
Also, it's only TVGuide.com that i'm running into issues with my Linux server.  I started this thread.
 
http://webgrabplus.com/content/tvguidecom-has-been-very-slow-lately-more-errors#comment-20869
 
So I figured if Zap2it gave me less problems, then it would be more ideal.  Like i said, when TVGuide.com is working, i don't have an issue with the speeds.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 1 hour

as i said u never checked ur WGLisence.log
if ur status is anything other than donator webgra will use delays while graqbbing.
this will explain why its taking soo long.
ur n0t first to post abt this(diff topic) but it will tell u a lot...

jhr1948
Offline
Donator
Joined: 1 year
Last seen: 1 day
Blackbear199 wrote:

as i said u never checked ur WGLisence.log
if ur status is anything other than donator webgra will use delays while graqbbing.
this will explain why its taking soo long.
ur n0t first to post abt this(diff topic) but it will tell u a lot...

 
Blackbear199, I did check the License log, look at my post above, i said i see it says 'donator_license'
 
the top says this:
[ Info ] No License update required
[ Info ] Next update, first run after : 2020/05/10 18:55
[ Info ] The program will run with performance settings : 'donator_license'
[ Info ] License check .. done
 
Anyway, figured i'd try something.  I opened the TVGuide website on the Linux server and there was a pop up from TVGuide asking to enable notificatitons.  I cleared that and thought if something like that could have caused speed issues.
 
Guess what, i'm running at normal speeds again.  Could that pop-up for notifications been the cause?

archer
Offline
Joined: 7 months
Last seen: 6 months

I'm having an issue with this ini as well. Specifically for provider and channel creation.

I have enabled the provider section by removing the comments in the ini.

Added this to my config with my zipcode at the site_id. (Replaced less than, greater than symbols with underscores)
_channel update="i" site="zap2it.com" site_id="myzip" xmltv_id="dummy"_dummy_/channel_

The file that is created just has this in it.
_channel update="i" site="zap2it.com" site_id="" xmltv_id=""_
_/channel_

From my log I get this.
[ Info ] ( 2/2 ) ZAP2IT.COM -- chan. (xmltv_id=zap2it providers) -- mode Force
[Warning ] no robots data found
[Warning ] skipped robots check
[Error ] Unable to update channel zap2it providers
[Critical] Generic syntax exception:
[Critical] message:
[Error ] no index page data received from zap2it providers
[Error ] unable to update channel, try again later

I'm able to create a providers list for tvguide and get channels list for tvguide and tvtv.us, so don't think I did anything wrong. Maybe something on the site changed since the ini was written?

Blob
Offline
Donator
Joined: 7 months
Last seen: 4 months

tvlistings.zap2it.com from the ini does not exist anymore.
[Warning ] error downloading page: The remote name could not be resolved: 'tvlistings.zap2it.com'

tvschedule.zap2it.com does exist, but the ini is probably going to need a rebuild.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl