You are here

Update tele.rtl.lu.ini

16 posts / 0 new
Last post
RaPt0r
Offline
Joined: 3 years
Last seen: 6 months
Update tele.rtl.lu.ini

Hi

Can you update this file please.

Thanks

fliyer
Offline
Donator
Joined: 1 year
Last seen: 1 week

The new URL is: url_index {url| https://www.rtl.lu/api/grille/tele/ |channel| / |urldate| }

but i have Problem to find the correct index_showsplit.scrub

RaPt0r
Offline
Joined: 3 years
Last seen: 6 months

Hi

Dont work

] Job started at 21/03/2019 20:22:52
[ Debug ]
[ Debug ] Running on: Microsoft Windows NT 6.2.9200.0
[ Debug ] Environment: 4.0.30319.42000
[ Debug ]
[ Debug ] Loading timezone data
[ Debug ] Embedded timezones source: timezone.timezonesdata.txt
[ Debug ] Reading config file: C:\WebGrab+Plus\WebGrab++.config.xml
[Warning ] timezone=UTC+01:00 mapped with timezone_id "Europe/Paris"
[ Debug ]
[ Info ] found: C:\WebGrab+Plus\siteini.pack\Luxembourg\tele.rtl.lu.ini -- Revision 01
[ Debug ] xmltv input file - C:\WebGrab+Plus\guide.xml - found
[ Debug ] 0 superfluous shows removed
[ Info ] Found existing channel (xmltv_id=RTL) in the config file
[ Info ] Found existing channel (xmltv_id=RTL 2) in the config file
[ Info ]
[ Info ]
[ Info ] i=index .=same c=change g=gab r=replace n=new
[ Info ]
[ Info ]
[ Info ] Group (0) :
[ Info ] update requested for - 2 - out of - 2 - channels for 3 day(s)
[ Debug ]
[ Info ] ( 1/2 ) TELE.RTL.LU -- chan. (xmltv_id=RTL) -- mode Force
[Error ] Unable to update channel RTL
[Critical] Generic syntax exception:
[Critical] message:
[Error ] no index page data received from RTL
[Error ] unable to update channel, try again later
[ Info ] No guide data to restore
[ Debug ]
[ Info ] ( 1/2 ) TELE.RTL.LU -- chan. (xmltv_id=RTL 2) -- mode Force
[Error ] Unable to update channel RTL 2
[Critical] Generic syntax exception:
[Critical] message:
[Error ] no index page data received from RTL 2
[Error ] unable to update channel, try again later
[ Info ] No guide data to restore
[ Debug ]
[ Debug ] 0 shows in 2 channels
[ Debug ] 0 updated shows
[ Debug ] 0 new shows added
[ Info ]
[ Info ]
[ ] Job finished at 21/03/2019 20:22:56 done in 3s

Attachments: 
Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 11 hours

[Error ] no index page data received
means wg could not connect to the url(http address you create in index_url line)
do u see the diff in ur ini?
hint..http vs https

this doent mean everything else is the same as the old site though,that u will have to check...

@flyer
sometimes for site like this its easier to scrub the block of all shows and then replace a unique string with what wegbrab uses as a separator(internally) to split them into individual programs,the vertical pipe | so u must escape it(like regex) so its \| to tell webgrab u want it used as a separator.

the rsult is the exact same thing as u get doing the showsplit all in one step.

there are many examples of this in many ini as i do it all the time with json data...

RaPt0r
Offline
Joined: 3 years
Last seen: 6 months

now with the right url

[ ] Job started at 22/03/2019 12:00:00
[ Debug ]
[ Debug ] Running on: Microsoft Windows NT 6.2.9200.0
[ Debug ] Environment: 4.0.30319.42000
[ Debug ]
[ Debug ] Loading timezone data
[ Debug ] Embedded timezones source: timezone.timezonesdata.txt
[ Debug ] Reading config file: C:\WebGrab+Plus\WebGrab++.config.xml
[Warning ] timezone=UTC+01:00 mapped with timezone_id "Europe/Paris"
[ Debug ]
[ Info ] found: C:\WebGrab+Plus\siteini.pack\Luxembourg\tele.rtl.lu.ini -- Revision 01
[ Debug ] xmltv input file - C:\WebGrab+Plus\guide.xml - found
[ Debug ] 0 superfluous shows removed
[ Info ] Found existing channel (xmltv_id=RTL) in the config file
[ Info ] Found existing channel (xmltv_id=RTL 2) in the config file
[ Info ]
[ Info ]
[ Info ] i=index .=same c=change g=gab r=replace n=new
[ Info ]
[ Info ]
[ Info ] Group (0) :
[ Info ] update requested for - 2 - out of - 2 - channels for 3 day(s)
[ Debug ]
[ Info ] ( 1/2 ) TELE.RTL.LU -- chan. (xmltv_id=RTL) -- mode Force
[Error ] no shows in indexpage!
[ Info ]
[ Debug ]
[ Info ] ( 2/2 ) TELE.RTL.LU -- chan. (xmltv_id=RTL 2) -- mode Force
[Error ] no shows in indexpage!
[ Info ]
[ Debug ]
[ Debug ] 0 shows in 2 channels
[ Debug ] 0 updated shows
[ Debug ] 0 new shows added
[ Info ]
[ Info ]
[ ] Job finished at 22/03/2019 12:00:05 done in 5s

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 11 hours

so does urs...

[ Debug ] skipped : no value for next starttime
[ Debug ] skipped show without a title at 22/03/2019 18:30:00

...
[ Info ] update requested for - 2 - out of - 2 - channels for 7 day(s)
[ Debug ]
[ Info ] ( 1/2 ) TELE.RTL.LU -- chan. (xmltv_id=RTL) -- mode Force
[ Debug ] skipped : last show, no next startime to use as stop
[ Info ] 0.00 sec/update
[ Debug ]
[ Info ] ( 2/2 ) TELE.RTL.LU -- chan. (xmltv_id=RTL 2) -- mode Force
[ Debug ] skipped : last show, no next startime to use as stop
[ Info ] 0.00 sec/update
[ Debug ]
[ Debug ] 301 shows in 2 channels
[ Debug ] 0 updated shows
[ Debug ] 301 new shows added

fliyer
Offline
Donator
Joined: 1 year
Last seen: 1 week

i get no result. i don´t know why. I think the regex entries are wrong

Attachments: 
fliyer
Offline
Donator
Joined: 1 year
Last seen: 1 week

Yes your right :) i have no idea what im doing. I Search all time for a faq for using regex with all signs. I try my best.mostly i use some inis and copy &paste to get some results

mat8861
Offline
WG++ Team memberDonator
Joined: 4 years
Last seen: 11 hours

in europe is last year we see:
[ Info ] ( 1/2 ) TELE.RTL.LU -- chan. (xmltv_id=RTL 1) -- mode Force
[ Debug ] coming 'Day-Light-Saving-Time' change!
[ Debug ] time-offset change for all shows after stoptime 20190331060000 +0200
[ Debug ] starting with show : Rediffusoune vu Journal, Sport, ArtBox a Review at local time 31/03/2019 06:00
[ Debug ] skipped : last show, no next startime to use as stop
[ Info ] 0.00 sec/update
[ Debug ]
[ Info ] ( 2/2 ) TELE.RTL.LU -- chan. (xmltv_id=RTL 2) -- mode Force
[ Debug ] coming 'Day-Light-Saving-Time' change!
[ Debug ] time-offset change for all shows after starttime 20190325010000 +0100
[ Debug ] starting with show : Editus.lu at local time 25/03/2019 01:00
[ Debug ] skipped : last show, no next startime to use as stop
[ Info ] 0.00 sec/update
[ Debug ]
[ Debug ] 299 shows in 2 channels
[ Debug ] 0 updated shows
[ Debug ] 299 new shows added
[ Info ]
[ Info ]
[ ] Job finished at 25/03/2019 17:46:27 done in 1s

doglover
Offline
Donator
Joined: 6 years
Last seen: 3 weeks

Try this

fliyer
Offline
Donator
Joined: 1 year
Last seen: 1 week

Finsih , and runs but they write a little to much descriptions at this moment. I´m missing more ( description remove ) details.

But for first is this OK.

Attachments: 
fliyer
Offline
Donator
Joined: 1 year
Last seen: 1 week

At the same time doglover :)

RaPt0r
Offline
Joined: 3 years
Last seen: 6 months
doglover wrote:

Try this

Hi

Thanks , work fine

Brgds

sicarius
Offline
Joined: 1 month
Last seen: 1 month

Hello, I receive the message that there are no shows in indexpage. Unfortunately my knowledge about adapting tele.rtl.lu.ini is too weak:

Found existing channel (xmltv_id=RTL Télé Lëtzebuerg HD) in the config file
Found existing channel (xmltv_id=2ten RTL HD) in the config file
....
i=index .=same c=change g=gab r=replace n=new
Group (0) :
update requested for - 2 - out of - 2 - channels for 14 day(s)
( 1/2 ) TELE.RTL.LU -- chan. (xmltv_id=RTL Télé Lëtzebuerg HD) -- mode Force
iiiiiii
no shows in indexpage!

( 2/2 ) TELE.RTL.LU -- chan. (xmltv_id=2ten RTL HD) -- mode Force
iiiiiii
no shows in indexpage!

Thank you in advance for replying.

mat8861
Offline
WG++ Team memberDonator
Joined: 4 years
Last seen: 11 hours
sicarius
Offline
Joined: 1 month
Last seen: 1 month

Thank you very much! Everything's working fine now :-)

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl