You are here

Trying to Upgrade to 2.1.5 on Ubuntu 16.04

3 posts / 0 new
Last post
jgrott33
Offline
Joined: 1 year
Last seen: 2 months
Trying to Upgrade to 2.1.5 on Ubuntu 16.04

v2.1 runs fine. v2.1.4 and v2.1.5 fails with the same error. I don't believe its my config or ini as they work fine if I roll back to v2.1

WebGrab+Plus/w MDB & REX Postprocess -- version V2.1.4

Jan van Straaten
Francis De Paemeleere

thanks to Paul Weterings and all the contributing users
--------------------------------------------------------------------------------

Job started at 25/07/2018 11:11:15
Job finished at 25/07/2018 11:11:16 done in 0s
Unhandled Exception

Method 'Array.Empty' not found.

at WGconsole.Program.ConsoleApplication (System.String[] args) <0x41ad9000 + 0x0750f> in :0
at WGconsole.Program.Main (System.String[] args) <0x41ad0f60 + 0x00087> in :0
For detailed info, see log file /root/.wg++/./WebGrab++.log.txt
Execution stopped

Mono version:

Mono JIT compiler version 4.2.1 (Debian 4.2.1.102+dfsg2-7ubuntu4)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
TLS: __thread
SIGSEGV: altstack
Notifications: epoll
Architecture: amd64
Disabled: none
Misc: softdebug
LLVM: supported, not enabled.
GC: sgen

jgrott33
Offline
Joined: 1 year
Last seen: 2 months

Going to upgrade my mono to v5

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
sudo apt install apt-transport-https
echo "deb https://download.mono-project.com/repo/ubuntu stable-xenial main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt update

dracoy
Offline
Joined: 8 months
Last seen: 1 week

Try this steps, and install mono complete.
It fix my problem with Ubuntu 16.04

Ps: After add the mono repository i run this comand sudo apt autoremove , i dont if it is really necessary or not.

http://www.mono-project.com/download/stable/#download-lin

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl