You are here

Stuck on v2.1

8 posts / 0 new
Last post
Freek
Offline
Joined: 1 year
Last seen: 11 months
Stuck on v2.1

I'm on a Raspberry Pi with hard-float and it seems like I'm unable to update v2.1 with any of the beta's. My mono version is 2.11.4 and the version of my OS is Unix 4.19.58.0 (according to the log file). I tried all updates from 2.1.1 to 2.1.10 but they all give errors. The way I tried to install them is by first installing v2.1, downloading and unpacking the update files so they overwrite the original ones.

Included is a zip file with a log file where I tried update 2.1.10. The site.ini I used is the only one working for me in v2.1. The channels.xml file included was pulled with v2.1 but I included it anyhow since the guidelines request this.

EDIT: I just realised I need to update mono. The install instructions for Raspi stated that I should never install another update on top of mono, but those instructions were a bit outdated :) Will report back if it still fails after this.

Attachments: 
Freek
Offline
Joined: 1 year
Last seen: 11 months

I'm unable to update mono as instructed here: https://www.mono-project.com/download/stable/#download-lin-raspbian

Could this be because I blacklisted it as instructed in the installation manual? How can I undo this?

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 11 hours

delete /etc/apt/preferences.d/mono-blacklist

did you install the mono version mentioned on the pi installation page?
if you did I would remove it(run the purge command again),this should remove all mono files then install it as it says on the mono download page.
for setup 2 install mono-complete instead of mono-devel.

Freek
Offline
Joined: 1 year
Last seen: 11 months

Yes, I followed instructions from the pi installation page. When I try to remove that file I get: can't remove '/etc/apt/preferences.d/mono-blacklist' no such file or directory.

I tried sudo apt install mono-complete again after that (did the other steps listed on mono-project.com) and it installed, but when I check with mono -V I'm still running 2.11.4.

When I try to run sudo apt install mono-complete another time, I get: mono-complete is already the newest version (6.0.0.334-0xamarin1+raspbian10b1) but it also states 140 not upgraded and can't read /etc/apt/preferences.d/ no such file or directory.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 11 hours

mono(from their site) probably install in your /opt folder.check that to see if you have a mono folder there.
since you didn't purge 2.11.4 like I said above the os is using the first mono binary it finds and its 2.11.4
so either purge all your mono versions and then install the latest again or you will need to specify the full path to mono version 6.0.0
something like

/opt/mono/bin/mono path/to/wg/exe/WebGrab+Plus.exe /path/to/wg/config/xml/WebGrab++.config.xml

Freek
Offline
Joined: 1 year
Last seen: 11 months

Right, I forgot about that one, my apologies. I tried sudo apt-get remove --purge mono* and rebooting but mono -V shows I'm still running 2.11.4.

Vertigo
Offline
Joined: 11 months
Last seen: 11 months

Ive had the same. Do as above to purge and remove any blacklists. Also do a ..whereis mono which will give you a set of dir. Then rm the list you get from the whereis

mat8861
Online
WG++ Team memberDonator
Joined: 5 years
Last seen: 3 min

i get it from website : https://www.mono-project.com/

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl