You are here

Request for www.тв-програма.bg ini

17 posts / 0 new
Last post
bulgar_webgrabber
Offline
Donator
Joined: 8 months
Last seen: 5 months
Request for www.тв-програма.bg ini

Hello, I have checked all publically available Bulgarian inis and most of them eather do not work or the site they were for no longer exits/shows TV schedule.

I have also check most popular sites showing Bulgarian TV schedules and defenatly https://www.тв-програма.bg / https://www.xn----8sbafg9clhjcp.bg/ has the most channels, most detailed information and offers full schedule for each week.

It would be great if someone could extend the Bulgarian support and include this site.

Yeah, the URL is in cyrillic.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 5 months

added to git,same place u got viacom files.

bulgar_webgrabber
Offline
Donator
Joined: 8 months
Last seen: 5 months

Thank you for your quick work, Blackbear199!

I have tested the ini but it looks like that there is some issue and it cashes WebGrab+Plus. Maybe related to the cyrilic DNS record?

I am running it ot Ubuntu 16.04 and Mono 6.12.0.107

Log:
[ Info ] ( 1/1 ) ТВ-ПРОГРАМА.BG -- chan. (xmltv_id=BNT) -- mode Force
[ ] Job finished at 28/01/2021 11:28:40 done in 1s
[Critical]
Index was outside the bounds of the array.
[Critical]
at  .․.  (System.String ,  .
, System.Int32 , System.Int32 , System.Boolean ,  .• ) [0x00545] in <896f87e576a8482c8f603908a14ec73f>:0
at  .―.  (System.String[] ) [0x00b9c] in <896f87e576a8482c8f603908a14ec73f>:0
[Critical] Unhandled Exception
[Critical] For detailed info, see log file /etc/conf/webgrab/./WebGrab++.log.txt
[Critical] Execution stopped

bulgar_webgrabber
Offline
Donator
Joined: 8 months
Last seen: 5 months

I have narrowed it down to the timespan parameter. If it is more than 3 it crashes. There is no data for more than 4 (including today) days at the site at the moment.

Will you be able to avoid the crashes in this situation?

Blackbear199
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 5 months

what channel are you getting the error on?
i have no prob getting 7 days.

bulgar_webgrabber
Offline
Donator
Joined: 8 months
Last seen: 5 months

I have tried a couple. I am attaching the logs when I am trying to grab the same channel as you - bTV. This time on Windows 10 getting basically the same error as on the Ubuntu machine.

Attachments: 
Blackbear199
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 5 months

edit this line,add (debug)

url_index {url(debug)|https://www.xn----8sbafg9clhjcp.bg/tv/|channel|/|urldate|}

run webgrab for 7 day grab and send webgrab log

bulgar_webgrabber
Offline
Donator
Joined: 8 months
Last seen: 5 months

Well, this line is actually encripted in the ini. Am I missing something?

Blackbear199
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 5 months

right,i forgot.
use this one(its unencrypted).i already added the debug part.

...file deleted,use one on git or siteini.pack

bulgar_webgrabber
Offline
Donator
Joined: 8 months
Last seen: 5 months

Log file in the attachments. Using the same config xml as above.

Attachments: 
Blackbear199
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 5 months

i think it may be a windows problem.
i asked mat8861 to try it and see if he gets same error,if so will contact the creator.
i use linux.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 5 months

works fine for mat8861,whats windows version are you using?
do u have another pc u can try it on?

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 1 hour

Please update to 3.1.5

bulgar_webgrabber
Offline
Donator
Joined: 8 months
Last seen: 5 months

OK, I will try the latest version. By the way, I am getting the same error on Ubuntu 16.04 as well. Both on V3.1.0.0.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 5 months

its a problem with 3.1.0,mat8861 tried it and got same error.

mat8861
Offline
WG++ Team memberDonator
Joined: 6 years
Last seen: 1 hour

3.1.5 works fine

Attachments: 
bulgar_webgrabber
Offline
Donator
Joined: 8 months
Last seen: 5 months

I can confirm the same. 3.1.5 works using the ini on both Windows and Linux.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl