You are here

Push / sync guide.xml to Synology NAS

5 posts / 0 new
Last post
sammyke007
Offline
Donator
Joined: 1 year
Last seen: 4 months
Push / sync guide.xml to Synology NAS

Hi

I've successfully configured WG+ in a Docker container on my homeserver.

What's the easiest method to sync or push this created guide.xml (in /opt/wg+/data/guide.xml on my homeserver) to my Synology NAS webfolder (/volume1/web on my Synology NAS)?

Or is there a better method?
I've tried running WG+ directly on my NAS, but it didn't work and I prefer the Docker image on my homeserver.

Tnx!

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 1 hour

do some searching,there are various ways todo this.
one way i can think of is to mount the location on your synology NAS on your homeserver,this way it would appear as a local drive and you can have webgrab write the guide.xml directly to it.

why do you need to transfer it to your synology,for epg for a app?
does your homeserver have a webserver?
if so you could host the guide.xml on it.

sammyke007
Offline
Donator
Joined: 1 year
Last seen: 4 months

After some wrestling today, it works! Damn permissions...

I've mounted a webfolder from my NAS on my homeserver. WG+ writes the generated.xml directly on the mount. Tnx for the tip!
It could've been probably easier by creating a local webserver on my homeserver itself, but it works...

I need the webserver to let TiViMate grab the XML.

Blackbear199
Offline
Blackbear199's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 1 hour

glad you got it figured out.
i suggest you make sure that you set tivimate to update after webgrab has completed.
when webgrab runs the guide.xml it updated in real time after each channels update is done.
it doesnt wait for the entire process to complete and update the guide.xml all at once like one might think it does.
so its possible that if tivimate does a update while webgrab is still running it will only get the updated epg for the channels that have completed.

Basroal teela
Offline
Joined: 7 months
Last seen: 7 months
Quote:

glad you got it figured out.
i suggest you make sure that you set tivimate to update after webgrab has completed.
when webgrab runs the guide.xml it updated in real time after each drift boss channels update is done.
it doesnt wait for the entire process to complete and update the guide.xml all at once like one might think it does.
so its possible that if tivimate does a update while webgrab is still running it will only get the updated epg for the channels that have completed.

same. it doesnt wait for the entire process to complete and update the guide.xml all at once like one might think it does.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl