You are here

New TVToday.ini / compared to m.tvtoday.ini

47 posts / 0 new
Last post
Christoph21x
Offline
Joined: 7 years
Last seen: 1 year
New TVToday.ini / compared to m.tvtoday.ini

Dear All

After only few days back, Blackbear updated the m.tvtoday.ini, I see a big loss of information (NOT due to Blackbear - a big thanks to him!!)

m.tvtoday.de now only offers limited information & a forecast for 6 days only.
So I decided to revive my initial TVToday.ini, which offers a forecast for 12 days.

Please find enclosed the new TVToday.ini which is a working first step to a complete new one.
The swap from m.tvtoday.ini to TVToday.ini is a very simple one in your config: simply replace all "m.tvtoday.ini" entries with "tvtoday.ini" - all channel information and names remain the same.

If you're scraping right now, you'll find some errors downloadning content for a few channels - this is due to errors in the program's link, not the scraper... It will skip then only one show. Will be gone in a few days, have to investigate...

Kind greetz from Switzerland - Chris

PS: the tvtoday.Puls8.ini file is not anymore needed - obsolete. Git pull request issued.

EDIT: FOUND A MAJOR ERROR AND DELETED ATTACHMENT. STAY TUNED

popy
Offline
Joined: 3 years
Last seen: 10 months

Hey Christoph21x.

Thx for keeping the ini's uptodate.
Currently using the mobile ini but since a few days i have no content.
Want to switch back to the full version (this here) and want to ask how is fixing of the stated error going?

thx

pOpY

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year
popy wrote:

Hey Christoph21x.

Thx for keeping the ini's uptodate.
Currently using the mobile ini but since a few days i have no content.
Want to switch back to the full version (this here) and want to ask how is fixing of the stated error going?

thx

pOpY

TVToday has now two different PAGE STRUCTURES for movies and for series' shows. Just testing the new ini that covers both in a final massive test....
What's still missing: actors; some channels show "download error" for single shows (it works, but requests some time).
Will publish the ini in a few minutes... if it worked

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year

NEW VERSION - HYBRID

TVToday has now different structures for movies and for series' Shows...
The new TVToday.ini covers both and will read movie's and show's information (unlike the version before).

Please donwload the attachment.

What's still open:
- There's still some "download errors" - which only skip individual shows
- Actors are not yet scraped.

Kind greetz - Chris

popy
Offline
Joined: 3 years
Last seen: 10 months

thx a lot, will test as asap.

Is for your new ini also a newer WebGrab+Plus versio required, like for the mobile one?
 

thx
pOpY

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year

YES, pOpY
Please let me know about your outcome...

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year
Blackbear199 wrote:

no offense christoph but that ini is a mess.other than the fact you sorted it by the date and i did it the hard way by actually sorting the shows..

your ini for a series show..

Ok, I delete it

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year

I don't like that kind of tone, am out.
Publish yours, I'm out, will use it for myself.

popy
Offline
Joined: 3 years
Last seen: 10 months

Guys, keep calm.
Why not work together and make the best INI out there?

@Blackbear199: Can you please upload your INI again and let the users decide which one to use?

thx
pOpY

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year
popy wrote:

Guys, keep calm.
Why not work together and make the best INI out there?

@Blackbear199: Can you please upload your INI again and let the users decide which one to use?

thx
pOpY

Thx pOpY,

Blackbear's are better... want to use them as well.

popy
Offline
Joined: 3 years
Last seen: 10 months

its now grabbing with your ini smiley
will see how it goes.

thx for the update!

popy
Offline
Joined: 3 years
Last seen: 10 months

Hey Christoph21x,

 

grabbing worked but sadly all epg data is shifted 2 hours back, ill think because we are in timezone +2h
Just using the same webgrab config file as on 1.57.

Am i missing a config option?

thx

pOpY

popy
Offline
Joined: 3 years
Last seen: 10 months

Update:

Set the timezone in the ini to: timezone=Europe/Rome
But sadly that doesnt fix the issue.

An entry in the xml looks like this:

  <programme start="20170920212500 +0200" stop="20170920215000 +0200" channel="ORF 1">
    <title lang="de">ZIB 24</title>
    <desc lang="de">().(n)</desc>
    <category lang="de">Nachrichten</category>
  </programme>

But the show starts on 23:25:00, it seems that Mediaportal ignores the +2000?

Any hints?

thx a lot
pOpY

 

 

popy
Offline
Joined: 3 years
Last seen: 10 months

Update 2:

Now i have added the following lines in the ini:

index_start.modify {calculate(format=utctime,HH:mm)}
index_stop.modify  {calculate(format=utctime,HH:mm)}

in combination with the set timezone the following is the output:

  <programme start="20170920232500 +0200" stop="20170920235000 +0200" channel="ORF 1">
    <title lang="de">ZIB 24</title>
    <desc lang="de">().(n)</desc>
    <category lang="de">Nachrichten</category>
  </programme>

now the times are correct in MP/Emby.
Not sure if this is right what i have done, can you please look at it and correct me if iam wrong?

Attached my current ini.

PS.: does this work when DST changes in october?

thx
pOpY

Attachments: 
Christoph21x
Offline
Joined: 7 years
Last seen: 1 year

Dear Popy & All
According to Blackbear my ini is "a mess".
So please Blackbear, publish your ini again.
@Popy: the results seem to be by far better
Let's not make users suffer.

popy
Offline
Joined: 3 years
Last seen: 10 months

Hey Christoph21x, it works, thats the most important thingsmiley

Can you please give me a hint if i have solved my UTC+2 issue correctly above?
Another thing i have noticed is that sometimes "n()" is in the resulted XML file (displayed in kodi).

Would be nice if you can look into the open issues (actors,...)

thx

pOpY

popy
Offline
Joined: 3 years
Last seen: 10 months

@Blackbear199: thx for the ini, will test it.

Regarding timezone, no i am not in UTC timezone, i am fro austria and we are UTC+1 + 1 DST = curently UTC+2.
With your old m.tvtoday.ini (before tvtoday changed the website) all shows where correctly alligned, but with new (from christoph) not.
I have nothing changed on my MP setup. With my "hack" i have shifted the times to my local time.
Read about the WG2MP tool before but never used it, as stated, havent touched my WG+MP setup.

To note, tvtoday is germany site, so the same timezone like mine (austria), maybe it has something todo with that?
Am i right, when using newer WG+ & MP i MUST use the WG2MP tool regarding changes in timezone logic?

So long story short answer/todo: will try your new ini and report back.

pOpY

popy
Offline
Joined: 3 years
Last seen: 10 months

Again me, looks very promising.
Sadly i have the timezone issue again.

Here is an show which starts at 20:00 local time, grabbed with your ini:

  <programme start="20170922180000 +0000" stop="20170922181500 +0000" channel="ORF 1">
    <title lang="de">ZIB 20</title>
    <desc lang="de">Keine Details!(n)</desc>
    <category lang="de">Nachrichten</category>
    <icon src="http://www.tvtoday.de/bundles/frontend/images/default-images/and_detail.jpg" />
  </programme>

Ill think the wrong timezone is set in your ini. With the following changes:

...
  site {url=tvtoday.de|timezone=Europe/Berlin|maxdays=12.1|cultureinfo=de-DE|charset=UTF-8|titlematchfactor=90}

...

  index_start.modify {calculate(format=utctime,HH:mm)}
  index_stop.modify  {calculate(format=utctime,HH:mm)}
  

it looks like this:

  <programme start="20170922200000 +0200" stop="20170922201500 +0200" channel="ORF 1">
    <title lang="de">ZIB 20</title>
    <desc lang="de">Keine Details!(n)</desc>
    <category lang="de">Nachrichten</category>
    <icon src="http://www.tvtoday.de/bundles/frontend/images/default-images/and_detail.jpg" />
  </programme> 

that should be right, isnt it?
I had found an webgrab+ site which states that "20170922200000 +0200" first part is time in local time and second how this is ahead to UTC.
Sadly did not finf the site now... :-(

Can you bring light in the darksmiley

Whats the behaviour of WG+ regarding timezones and how should it be?
Here are the facts:

  • tvtoday is UTC+2 now (Europe/Berlin)
  • i am in UTC+2 now (Europe/Berlin)

And the questions:

  • the timezone setting in the ini, must it be the timezone of the site?
    If yes, it should be "Europe/Berlin"...
  • how should an XML time looke like "20170922200000 +0200" -> "TIMESTR OFFSET"
    • must TIMESTR be UTC or LOCAL TIME
    • must OFFSET be added/substracted to get the local or UTC time

Youll see, i am a noob, hope you know what ill mean.

pOpY

 

 

popy
Offline
Joined: 3 years
Last seen: 10 months

And me number 3, just two minor issues i have noticed:

  • in details there is a trailing (n)
  • Genre isnt displayed in MP

the xml entry:

  <programme start="20170922200000 +0200" stop="20170922201500 +0200" channel="ORF 1">
    <title lang="de">ZIB 20</title>
    <desc lang="de">Keine Details!(n)</desc>
    <category lang="de">Nachrichten</category>
    <icon src="http://www.tvtoday.de/bundles/frontend/images/default-images/and_detail.jpg" />
  </programme> 

See attachment how it looks in Kodi.

thx a lot
pOpY

 

Attachments: 
Christoph21x
Offline
Joined: 7 years
Last seen: 1 year
Blackbear199 wrote:

christoph i seen your past work and its excellent.u didnt miss anything that webgrab could scrub.

[...]

any way i will post my versions.i've said this before and i'll say it again.

Thank you!

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year

Dear All
A huge thanks to Blackbear for his work... runs like a charm, which I never could have done.

Made some small adjustments (Rev. No & Author remained the same; source of Blackbear only partly commented out & partly other sequence):
- Removed trailing spaces in description
- Changed episode-num scraping to a standardized format for compatibility reasons to earlier TVToday site layout:
  - "St. 1, Folge 5" --> "Staffel 1, Folge 5"
  - "St. 1, Folge 5/10" --> "Staffel 1, Folge 5"
- Added episode information (if any) at the end of the description (needed by Argus TV users to select individual seasons he/she wants to record or to exclude)

pOpY, could you pls test, too?

Kind greetz from Switzerland - Chris

Attachments: 
popy
Offline
Joined: 3 years
Last seen: 10 months

@Blackbear199:

thx a lot for the explanation, now its clear to me.
Now using your ini and WG2MP, timestamps are now correct in MP/Kodi.
Also thx for the hint regarding the (n), didnt know about that :-)

Regarding genre:
As you can see in my jpg at post #24: http://www.webgrabplus.com/comment/11595#comment-11595
The genre is empty in kodi, no matter which show or movie.
but in the xml file (snippet also at post #24) there is category "Nachrichten", which is the genre.

Is this fixable?

thx
pOp>

popy
Offline
Joined: 3 years
Last seen: 10 months

@Christoph21x:

thx Chris, test running ... wil reply back.
Can you also please look into the genre issue(my previous post)? 

pOpY

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year
popy wrote:

thx Chris, will test and reply back.
Can you also please look into the genre issue(my previous post)? 

pOpY

Do you mean "Category"? This is filled here correctly...

popy
Offline
Joined: 3 years
Last seen: 10 months
Christoph21x wrote:

popy wrote:

thx Chris, will test and reply back.
Can you also please look into the genre issue(my previous post)? 

pOpY

Do you mean "Category"? This is filled here correctly...

yep, should'nt that be the displayed genre in kodi?
here is an example from my xml on the show "ZIB 20" which is an "News/Nachrichten" genre:

  <programme start="20170922200000 +0200" stop="20170922201500 +0200" channel="ORF 1">
    <title lang="de">ZIB 20</title>
    <desc lang="de">Keine Details!(n)</desc>
    <category lang="de">Nachrichten</category>
    <icon src="http://www.tvtoday.de/bundles/frontend/images/default-images/and_detail.jpg" />
  </programme> 

Sorry if ill got this wrong not so deep in the ini/grabbing/xml thing, maybe its nonsens what ill write smiley
But ill thougth, hey there is an category Info the xml which states the genre and in kodi its not displayed.

thx pOpY

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year

Small Change:
- "role=" --> "Rolle: "

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year

i should add in my example i dont move the category information but is easy to add.[/quote]

Sounds logical.
Could you add it to my latest? see previous post

popy
Offline
Joined: 3 years
Last seen: 10 months
Christoph21x wrote:

Dear All
A huge thanks to Blackbear for his work... runs like a charm, which I never could have done.

Made some small adjustments (Rev. No & Author remained the same; source of Blackbear only partly commented out & partly other sequence):
- Removed trailing spaces in description
- Changed episode-num scraping to a standardized format for compatibility reasons to earlier TVToday site layout:
  - "St. 1, Folge 5" --> "Staffel 1, Folge 5"
  - "St. 1, Folge 5/10" --> "Staffel 1, Folge 5"
- Added episode information (if any) at the end of the description (needed by Argus TV users to select individual seasons he/she wants to record or to exclude)

pOpY, could you pls test, too?

Kind greetz from Switzerland - Chris

works, but i had some timeouts and exceptions, look at the attachment.
Currently running the grab and will compare (beyond compare) the result with the version from blackbear.

pOpY

Attachments: 
popy
Offline
Joined: 3 years
Last seen: 10 months

@Christoph21x: your ini looks good (the one without the role change), have compared the resulting xml with beyond compare and on every show the Staffel/Episodes are changed.

@Blackbear199: thx for the hint, will try that later

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year
Blackbear199 wrote:

Small Change:
- "role=" --> "Rolle: "

u cannot do this as the role= is a feature of the new xmltv attrubutes avail since version 2.1.1 so the value role= actually means something to webgrab where "Rolle:" doesnt.

this is what adds the role attribute to the actors name(when it exists).

example

<actor role="Franz Eberhofer">Sebastian Bezzel</actor> 

changing this will mess up the actor tag.

 

Only changed the description entry, not the tags

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year
Blackbear199 wrote:

where did you get the channel "EinsExtra" from?

i dont see it in the channels.xml or on the site.

"EinsExtra" not existing anymore

popy
Offline
Joined: 3 years
Last seen: 10 months
Christoph21x wrote:

Blackbear199 wrote:

where did you get the channel "EinsExtra" from?

i dont see it in the channels.xml or on the site.

"EinsExtra" not existing anymore

Sorry my fault. Have alread deleted channel in MP SetupTV but not in WG+ Config.
Have deleted the channel to grab.

popy
Offline
Joined: 3 years
Last seen: 10 months
Blackbear199 wrote:

Christoph21x wrote:

i should add in my example i dont move the category information but is easy to add.

Sounds logical.
Could you add it to my latest? see previous post

what your doing is editing the ini to move elements to where you want them,i leave the ini as original and ue rex to move/delete elements.this is what the rex post processor was created for.if i wanted to move the category to the description...

<?xml version="1.0" encoding="utf-8"?>

<settings>

  <filename>/raid/NAS_WebGrab/IPTV/rex/rex_guide.xml</filename>
 
  <title>'title' {('productiondate')}</title>
  <desc>{Subtitle: 'subtitle'\n}{Episode: 'episode'\n}'description'{\nCategory: 'category(, )'}{\nDirector: 'director(, )'}{\nActors: 'actor(, )'}{\nPresenter: 'presenter(, )'}</desc>
  <sub-title></sub-title>
  <credits></credits>

  <category></category>

  <date></date>
  <rating></rating>
  <star-rating></star-rating>
  <episode-num></episode-num>
  <subtitles />

</settings>

dont mind the spaces above/below <category> it because i copied it from post above.

{\nCategory: 'category(, )'} - adds a new line (\n) then the category element(separated by a comma if more than 1).

                                              enclosing it in {} means that if no category info exists nothing is added.

                                              without these you would get a , and nothing else.

<category></category> removes the element from the guide.xml.

why have it in 2 places,just makes the file bigger.

                            

[/quote]

 

will try that, thx

popy
Offline
Joined: 3 years
Last seen: 10 months

works perfect, thx

popy
Offline
Joined: 3 years
Last seen: 10 months

Hey guys.

One small issue i have found, something like this in xml:

<actor>Johnny Galecki(role=Leonard Hofstadter</actor>

 

Any hints?

thx a lot

popy
Offline
Joined: 3 years
Last seen: 10 months

Channel is orf 1, here is the complete entry :

Edit:sorry can't post the xml part because I am on road.

popy
Offline
Joined: 3 years
Last seen: 10 months

Thx, used Chris one,maybe too old one. Will look at this when I am at home.

Another question regarding Rex, using this now to customize my description in kodi. Sadly I can't insert a line break, when I'll use \n as suggested, this adds a line break in resulting xml but kodi doesn't show it. All info in one line. Would be nice if you have a hint here for me

Thx

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year

Hi Blackbear
Yes thanks, I know about the "role" issue; I just forgot to delete the attachment.
In the meantime I use a (unpublished) tweak without the text Role/Rolle at all, that speeded up my import by approx. 7%, as Argus TV simply adds all actors plus roles to the description. Leaving out the word role speeds up already a lot.

Which Software uses this "role=" tag, by the way? Do you know one?

In the latest published "official" is one minor bug: Line 79 must be "temp_1.scrub {regex()||<li class="h8">St\.(.*?)[/<]||}" (remove the "arguments" in regex(arguments))

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year
Blackbear199 wrote:

i dont know any that use the role attribute.a quick search suggest windows media center as one.

the bug your refering to on line 79 if for your tweaked version only.mine doesnt use this.

Should have been in my last cleaned up version (prior to role change) after your upload. It's not leading to misbehaviour, it works, it's just not correct.
Attached here: http://www.webgrabplus.com/comment/11598#comment-11598
Just corrected the ini already

popy
Offline
Joined: 3 years
Last seen: 10 months

thx guys regarding the role, a new scrub is running right now....

Blackbear199 wrote:

no idea on that one as i use \n in rex also and use kodi and it works fine.

are you doing anything to the guide.xml(after rex) via a script or anything else?

yes, after REX now i am using WG2MP, but it should not affect the result.
Will check this when scrub is ready.

What chain/apps do you use?
I am using:

WG+ with REX -> WG2MP (to correct timestamps) -> XML -> XMLtv plugin of MP tvserver -> Kodi v17.3

popY
 

Christoph21x
Offline
Joined: 7 years
Last seen: 1 year
popy wrote:

What chain/apps do you use?
I am using:
WG+ with REX -> WG2MP (to correct timestamps) -> XML -> XMLtv plugin of MP tvserver -> Kodi v17.3

WG (no REX) --> Argus TV --> automatically transferred to Kodi 17.4

popy
Offline
Joined: 3 years
Last seen: 10 months

Thx guys, so we are using the same components.

I have found the solution to get line breaks working :-)
Just use the new xml importer from this post: https://forum.team-mediaportal.com/threads/epg-daten-fuer-mediaportal.12...

And voila, line break import is working.

Now my tvguide.xml looks very good (role & line breaks fixed).

thx pOpY

 

 

popy
Offline
Joined: 3 years
Last seen: 10 months

Hey guys.

I have some html parts in the "desc", see this show:

  <programme start="20180412181500 +0000" stop="20180412191500 +0000" channel="RTL-N">
    <title lang="de">MythBusters: The Search</title>
    <sub-title lang="de">Die A-Team-Challenge</sub-title>
    <desc lang="de">Wer wird Teil des neuen „MythBusters“-Duos? Diesmal müssen die Anwärter wie in der TV-Serie „Das A-Team“ aus Fundstücken vom Schrottplatz eine funktionstüchtige Waffe herstellen. Doppelfolge.&lt;div&lt;p class="main-copy"&gt; (Folge 5&lt;).</desc>
    <credits>
      <director>Yvette Solis</director>
    </credits>
    <date>2017</date>
    <category lang="de">Dokureihe</category>
    <episode-num system="onscreen">Folge 5&lt;</episode-num>
  </programme>

Can you please look into it?

thx
pOpY

popy
Offline
Joined: 3 years
Last seen: 10 months
Blackbear199 wrote:

WG --> REX --> WG2MP ---> kodi 17.3

Christoph21x wrote:

popy wrote:

What chain/apps do you use?
I am using:
WG+ with REX -> WG2MP (to correct timestamps) -> XML -> XMLtv plugin of MP tvserver -> Kodi v17.3

WG (no REX) --> Argus TV --> automatically transferred to Kodi 17.4

Guys are you here? angel

popy
Offline
Joined: 3 years
Last seen: 10 months

Have fixed the issue with an workaround.
Attached the new ini.

Attachments: 
Christoph21x
Offline
Joined: 7 years
Last seen: 1 year
popy wrote:

Have fixed the issue with an workaround.
Attached the new ini.

Hallo popy, ganz herzlichen Dank!
LG aus der Schwiiz

popy
Offline
Joined: 3 years
Last seen: 10 months
Christoph21x wrote:

popy wrote:

Have fixed the issue with an workaround.
Attached the new ini.

Hallo popy, ganz herzlichen Dank!
LG aus der Schwiiz

Bitte Gerne :-)

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl