You are here

Linux Installation problem

3 posts / 0 new
Last post
aarronlee
Offline
Joined: 5 years
Last seen: 2 years
Linux Installation problem

Hi,

I have been using Webgrab for many years on windows...

I just installed it on ubuntu 15.10 and copied all of my .ini files into the linux folder...

I run this command:

cd ~/wg && mono WebGrab+Plus.exe

 

I get this error:

config file C:\ProgramData\ServerCare\WebGrab\WebGrab++.config.xml doesn't exist
execution stopped
Load timezone data error!
Consult the documentation
Execution stopped

 

 

I also run this:

maria@maria-p6-2027es:~/wg$ mono WebGrab+Plus.exe "$(pwd)"

 

And I get this error:

          WebGrab+Plus/w MDB & REX Postprocess -- version 1.1.1/55.27           

                                Jan van Straaten                                
                             Francis De Paemeleere                              

            thanks to Paul Weterings and all the contributing users             
--------------------------------------------------------------------------------

file /home/maria/wg/guide.xml not found, creating a new one .. 
Unhandled exeption
Exception.Message: Cannot cast from source type to destination type.

 

This is my log file:

[  Debug ] WebGrab+Plus/w MDB & REX Postprocess -- version 1.1.1/55.27 -- Jan van Straaten 
[  Debug ] --------------------------------------------------------------------------------
[  Debug ] job started at 08/02/2016 23:32:08
[  Debug ] 
[  Debug ] reading config file: /home/maria/wg/WebGrab++.config.xml
[  Debug ] loading timezone data
[  Debug ] embedded timezones source: WGconsole.WG.Common.timezonesdata.txt
[  Debug ] found: /home/maria/wg/tikitaka.ini -- Revision 0
[  Debug ] found: /home/maria/wg/taq01.ini -- Revision 0
[  Debug ] found: /home/maria/wg/taq02.ini -- Revision 0
[  Debug ] found: /home/maria/wg/taq03.ini -- Revision 0
[  Debug ] found: /home/maria/wg/taq04.ini -- Revision 0
[  Debug ] found: /home/maria/wg/taq05.ini -- Revision 0
[  Debug ] found: /home/maria/wg/taq06.ini -- Revision 0
[  Debug ] found: /home/maria/wg/taq07.ini -- Revision 0
[  Debug ] found: /home/maria/wg/elpais.com.ini -- Revision 1
[  Debug ] found: /home/maria/wg/sincroguia.tv.ini -- Revision 8
[  Debug ] timezone=UTC+01:00 mapped with timezone_id "Europe/Paris"
[  Debug ] found: /home/maria/wg/cine3d.ini -- Revision 0
[  Debug ] found: /home/maria/wg/elmundo.es.ini -- Revision 11
[  Debug ] found: /home/maria/wg/deporteshd.ini -- Revision 0
[  Debug ] found: /home/maria/wg/noepg.ini -- Revision 0
[  Debug ] found: /home/maria/wg/ppv.ini -- Revision 0
[  Debug ] found: /home/maria/wg/laguiatv.abc.es.ini -- Revision 0
[  Debug ] timezone=UTC+01:00 mapped with timezone_id "Europe/Paris"
[  Debug ] found: /home/maria/wg/kisstv.ini -- Revision 0
[  Debug ] found: /home/maria/wg/uk-sky.com.ini -- Revision 5
[  Debug ] timezone=UTC+01:00 mapped with timezone_id "Europe/Paris"
[  Debug ] found: /home/maria/wg/noservice.ini -- Revision 0
[  Debug ] found: /home/maria/wg/shoofeetv.com.ini -- Revision 0
[  Debug ] timezone=UTC-01:00 mapped with timezone_id "Atlantic/Azores"
[  Debug ] found: /home/maria/wg/entertainment.ie.ini -- Revision 3
[  Debug ] timezone=UTC+00:00 mapped with timezone_id "Atlantic/Canary"
[  Debug ] found: /home/maria/wg/open.telekom.rs.ini -- Revision 2
[  Debug ] timezone=UTC+01:00 mapped with timezone_id "Europe/Paris"
[  Debug ] found: /home/maria/wg/en.beinsports.net.ini -- Revision 5
[  Debug ] timezone=UTC+02:00 mapped with timezone_id "Europe/Athens"
[  Debug ] found: /home/maria/wg/se.timefor.tv.ini -- Revision 2
[  Debug ] timezone=UTC+01:00 mapped with timezone_id "Europe/Paris"
[  Debug ] found: /home/maria/wg/port.ro.ini -- Revision 9
[  Debug ] found: /home/maria/wg/portalnacional.com.pt.ini -- Revision 1
[  Debug ] found: /home/maria/wg/dk.timefor.tv.ini -- Revision 5
[  Debug ] timezone=UTC+01:00 mapped with timezone_id "Europe/Paris"
[  Debug ] found: /home/maria/wg/movietele.it.ini -- Revision 1
[  Debug ] timezone=UTC+01:00 mapped with timezone_id "Europe/Paris"
[  Debug ] found: /home/maria/wg/ipko.com.ini -- Revision 1
[  Debug ] timezone=UTC+01:00 mapped with timezone_id "Europe/Paris"
[  Debug ] found: /home/maria/wg/adult.ini -- Revision 0
[  Debug ] 
[  Debug ] running  on: Unix 4.2.0.28
[  Debug ] environment: 4.0.30319.17020
[  Debug ] mono version: 3.2.8 (Debian 3.2.8+dfsg-4ubuntu4)
[  Debug ] 
input file /home/maria/wg/guide.xml not found   ... created a new one ... 
[  Error ] Unhandled exeption
[  Error ] Exception.Message: Cannot cast from source type to destination type.

 

I have attached my setup

 

 

 

Thanks

 

Attachments: 
1NSdbZVbpZDX
Offline
Joined: 6 years
Last seen: 2 years

cd $HOME/wg/ && mono WebGrab+Plus.exe "$(pwd)"

else try other WG version

francis
Offline
francis's picture
WG++ Team memberDonator
Joined: 8 years
Last seen: 1 month
Is the support helpful?
support us

Seems that you have a channel without a name.

That should not occur, so just change it and you'll be fine.

It's:

<channel update="i" site="elpais.com" site_id="%230" xmltv_id="Plus"></channel>

So change it like eg:

<channel update="i" site="elpais.com" site_id="%230" xmltv_id="Plus">Plus</channel>
Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl