You are here

errors the new version 3

16 posts / 0 new
Last post
tase68
Offline
Donator
Joined: 2 years
Last seen: 1 week
errors the new version 3

Hello everyone I'm trying to install the new version 3
but i get errors and i can't get the installation, can someone help me?
I send together my complete .WG++ folder and the guide.xml file
Operating system: Linux 16.04
Mono version: 6

Checking License ..
Job finished at 13/09/2020 16:14:08 done in 3s

(The remote server returned an error: (403) Server failed to authenticate the request. Make sure the value of Authorization header is formed correctly including the signature..

at Microsoft.WindowsAzure.Storage.Core.Executor.Executor.ExecuteSync[T] (Microsoft.WindowsAzure.Storage.Core.Executor.RESTCommand`1[T] cmd, Microsoft.WindowsAzure.Storage.RetryPolicies.IRetryPolicy policy, Microsoft.WindowsAzure.Storage.OperationContext operationContext) [0x00708] in :0
at Microsoft.WindowsAzure.Storage.File.CloudFile.Exists (Microsoft.WindowsAzure.Storage.File.FileRequestOptions options, Microsoft.WindowsAzure.Storage.OperationContext operationContext) [0x0001b] in :0
at WG_Azure.Azure_Access.DownloadFile (Microsoft.WindowsAzure.Storage.File.CloudFileDirectory dir, System.String filename, System.String& content, System.DateTime& lastmodified, System.Boolean& pass) [0x0001e] in :0
at WG_Azure.Azure_Access.DownloadFile (Microsoft.WindowsAzure.Storage.File.CloudFileDirectory dir, System.String filename, System.String& content) [0x00000] in :0
at  .–..ctor (System.Collections.Generic.Dictionary`2[TKey,TValue] , System.Boolean ) [0x0042f] in :0
at  . ..ctor (System.String ) [0x012c0] in :0
at  .―.  (System.String[] ) [0x00347] in :0
Unhandled Exception
For detailed info, see log file /root/.wg++/./WGLicense.log.txt)

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 4 days

could be a few things,did you install mono complete(this should install ca certificates).
if you did,try updating certificates..(u may have to use sudo if you dont have admin rights).
https://www.mankier.com/1/cert-sync
scroll down to the examples.

tase68
Offline
Donator
Joined: 2 years
Last seen: 1 week

Thanks in advance for your answer Mate
but I didn't really understand the solution to solve the problem ..
Can help please.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 4 days

todo that i need some more info.
did you install mono complete?
did u try updating ca-certificates as described in the link above(ubuntu is debian based so use that line in the examples)?

https://www.mono-project.com/download/stable/#download-lin
in step 2 install mono-complete instead of mono-devel

tase68
Offline
Donator
Joined: 2 years
Last seen: 1 week

thanks again for your reply ..
Now I'm getting this error can it help?

~/.wg++/run.sh

WebGrab+Plus/w MDB & REX Postprocess -- version V3.1.0.0

Jan van Straaten
Francis De Paemeleere

thanks to Paul Weterings and all the contributing users
--------------------------------------------------------------------------------

Job started at 14/09/2020 00:28:17
Job finished at 14/09/2020 00:28:18 done in 0s

[Error ] WG.Common.InvalidConfigException: [Error ] Corrupt config file[Error ] An XML comment cannot contain '--', and '-' cannot be the last character. Line 18, position 5.
at  . ..ctor (System.String ) [0x00079] in <896f87e576a8482c8f603908a14ec73f>:0

at  . ..ctor (System.String ) [0x012f6] in <896f87e576a8482c8f603908a14ec73f>:0
at  .―.  (System.String[] ) [0x00351] in <896f87e576a8482c8f603908a14ec73f>:0
Config syntax exception:
file: /root/.wg++/WebGrab++.config.xml

message:
WG.Common.InvalidConfigException: [Error ] Corrupt config file[Error ] An XML comment cannot contain '--', and '-' cannot be the last character. Line 18, position 5.
at  . ..ctor (System.String ) [0x00079] in <896f87e576a8482c8f603908a14ec73f>:0
For detailed info, see log file /root/

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 4 days

your webgrab config file is corrupt(most likely a typo).
An XML comment cannot contain '--', and '-' cannot be the last character. Line 18, position 5.

tase68
Offline
Donator
Joined: 2 years
Last seen: 1 week

Hello Mate
along send the photo of my file.xml
can you see what's wrong?

best regards

Attachments: 
tase68
Offline
Donator
Joined: 2 years
Last seen: 1 week

Once again hello Mate
I think I solved the problem mentioned above.
Now I face another one I get the information that skipped -> encrypted
and I'm only authorized to 20 channels ..
you can check that in the conf.xml file I added my username, email, and license number.

Again I ask for help

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 4 days

your config is a mess.
any thing between <!-- and --> is considered comments!.
now look at your ini and seee where u have these,your decrypt and lcense lines are disabled.
check here for the proper format.
http://webgrabplus.com/documentation/configuration/webgrabconfigxml
you will see anything the uses the tags i mentioned above is mostly used for a comment.
they can also be used to disable a line or multiple lines.

tase68
Offline
Donator
Joined: 2 years
Last seen: 1 week

Thank you very much for your help I think it has been resolved ..
A question how much will it be necessary to donate in order to have epg of more than 250 channels?

best regards

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 4 days

you would need a custom license.
contact jan(admin).u can find his email under contact tab at top of forums.

mat8861
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 18 hours
tase68 wrote:

Thank you very much for your help I think it has been resolved ..
A question how much will it be necessary to donate in order to have epg of more than 250 channels?
best regards

Not much i guess...250=5€...500=10€ ...should be something like that.

tase68
Offline
Donator
Joined: 2 years
Last seen: 1 week

Hello everyone
As I mentioned in the post above I finally got the configuration successfully, I added 2 days of EPG to the conf.xml.
the problem I have now and the next two end tomorrow and have not been updated for another 2 days. My question what do we have to add in the settings for the server to update?

mat8861
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 18 hours

there is a setting in config "update" mode http://webgrabplus.com/documentation/configuration/webgrabconfigxml#conf... togheter with timespan which is zero based so to grab a week you set to 6 (depends also on sites, some site offer only 3-4 days epg) Then if you mean "server" like linux you can set a cron job, linux has crontab, an utility to set commands to run x many times whenever you want, just search forum, it has been discussed lots of time.

tase68
Offline
Donator
Joined: 2 years
Last seen: 1 week

Hello mate
conf.xml file added timespan 2 timespan
to get epg valid for 3 days, my problem is at the end of those 3 days my server does not update automatically, so I ask if you know any script for linux to automatically run the update every 3 days please send me.

best regards

mat8861
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 18 hours
Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl