You are here

Error with Logger - Could not load file or assembly logger

8 posts / 0 new
Last post
dvxyz
Offline
Joined: 10 months
Last seen: 10 months
Error with Logger - Could not load file or assembly logger

Hi

with (beta)-version 2.1.7, and onwards on Ubuntu 19.10 (x64) I get the following error - v2.1 with the same scripts and config files works fine.

vuuno@ubuntubox:~/.wg++$ uname -a
Linux ubuntubox 5.3.0-19-generic #20-Ubuntu SMP Fri Oct 18 09:04:39 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

vuuno@ubuntubox:~/.wg++$ mono -V
Mono JIT compiler version 5.18.0.240 (Debian 5.18.0.240+dfsg-3 Mon Jun 24 08:50:44 UTC 2019)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
TLS: __thread
SIGSEGV: altstack
Notifications: epoll
Architecture: amd64
Disabled: none
Misc: softdebug
Interpreter: yes
LLVM: supported, not enabled.
Suspend: preemptive
GC: sgen (concurrent by default)

vuuno@ubuntubox:~/.wg++$ ./testrun.sh

Unhandled Exception:
System.TypeLoadException: Could not load type of field 'WG.Common.InvalidSyntaxException:3' (3) due to: Could not load file or assembly 'logger, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type of field 'WG.Common.InvalidSyntaxException:3' (3) due to: Could not load file or assembly 'logger, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

vuuno@ubuntubox:~/.wg++$

Thanks a lot.

D

mat8861
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 26 min

for encrypted siteini you need wg+ 2.1.9 or more http://webgrabplus.com/download/sw/v2.1.11

dvxyz
Offline
Joined: 10 months
Last seen: 10 months

Hi

thanks for your comment, however I get that same sort of error with v2.1.7, v2.1.9 or v2.1.11:

vuuno@ubuntubox:~/.wg++-2-1-11$ ./testrun.sh

Unhandled Exception:
System.TypeLoadException: Could not load type of field 'WG.Common.InvalidSyntaxException:3' (3) due to: Could not load file or assembly 'logger, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type of field 'WG.Common.InvalidSyntaxException:3' (3) due to: Could not load file or assembly 'logger, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.

Regards,

D

mat8861
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 26 min

make sure you have all the files, you should have the .exe and 3 .dll files

dvxyz
Offline
Joined: 10 months
Last seen: 10 months

Hi

thanks for the input, yes, I do have 3 exes and 3 dlls in place - I assume the 3rd exe is the link to the actual exe.
To add some context, I did a copy of my working v2.1 and extracted the beta files overwriting any existing file:

v2.1.11)

vuuno@ubuntubox:~/.wg++-2-1-11$ find . \( -name '*.dll' -or -name '*.exe' \) -exec ls -allh {} \;
lrwxrwxrwx 1 vuuno vuuno 20 oct 31 13:57 ./WebGrab+Plus.exe -> bin/WebGrab+Plus.exe
-rwxrwxr-x 1 vuuno vuuno 9,5K sep 4 11:24 ./bin/logger.dll
-rwxrwxr-x 1 vuuno vuuno 197K sep 4 11:24 ./bin/timezone.dll
-rwxrwxr-x 1 vuuno vuuno 675K sep 4 11:24 ./bin/WebGrab+Plus.exe
-rwxrwxr-x 1 vuuno vuuno 84K sep 4 11:24 ./bin/xmltv.dll
-rw-rw-r-- 1 vuuno vuuno 9,5K oct 31 13:57 ./xmltv_time_correct.exe
vuuno@ubuntubox:~/.wg++-2-1-11$

v2.1)

vuuno@ubuntubox:~/.wg++-2-1$ find . \( -name '*.dll' -or -name '*.exe' \) -exec ls -allh {} \;
lrwxrwxrwx 1 vuuno vuuno 20 nov 29 2018 ./WebGrab+Plus.exe -> bin/WebGrab+Plus.exe
-rwxrwxr-x 1 vuuno vuuno 597K jun 19 2017 ./bin/WebGrab+Plus.exe
-rwxrwxr-x 1 vuuno vuuno 33K jun 19 2017 ./bin/xmltv.dll
-rwxrwxr-x 1 vuuno vuuno 9,5K abr 11 2019 ./bin/logger.dll
-rwxrwxr-x 1 vuuno vuuno 197K abr 11 2019 ./bin/timezone.dll
-rw-rw-r-- 1 vuuno vuuno 9,5K ene 6 2011 ./xmltv_time_correct.exe
vuuno@ubuntubox:~/.wg++-2-1$

BR

D

mat8861
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 26 min

bit confused but i would try to cd to /home/user/desktop/.wg++ (or whatever your path to folder is) and then run from cli
root@ubuntu:/home/ubuntu/Desktop/.wg++# mono WebGrab+Plus.exe

dvxyz
Offline
Joined: 10 months
Last seen: 10 months

If it’s serious and not a bad joke, I’m explaining my car isn’t starting and you basically ask me if it’s starting when I turn the key sitting on the passengers seat.

The testrun.sh basically does the mono WebGrab+Plus.exe part:

vuuno@ubuntubox:~$ cat /home/vuuno/.wg++-2-1-11/testrun.sh
#!/bin/bash

#/**
# * @file run.sh
# * @brief just start WebGrab+Plus
# * @author Francis De Paemeleere
# * @date 31/07/2016
# */

#backup the current working dir
WG_BCKP_DIR="$(pwd)"

function quit {
#restore previous working dir
cd "$WG_BCKP_DIR"
exit $1;
}

# check if mono can be found
which mono >/dev/null 2>&1 || { echo >&2 "Mono required, but it's not installed."; quit 1; }

# get the absolute path of the link (or relative path)
if [ -L $0 ] ; then
DIR=$(dirname $(readlink -f $0)) ;
else
DUTDIR=$(dirname $0) ;
if [ "${DUTDIR:0:1}" = "/" ]; then
DIR="$DUTDIR";
else
DIR=$PWD/$(dirname $0) ;
fi
fi ;

cd "$DIR"

mono "WebGrab+Plus.exe" "$DIR/test_config"
# mono "xmltv_time_correct.exe" "testguide.tmp.xml" "testguide.xml"
quit 0;

vuuno@ubuntubox:~$

mat8861
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 26 min

do not run .sh just run "mono WebGrab+Plus.exe" in cli while you are in folder you use

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl