You are here

Error after clean install 2.1 and 2.1.11

7 posts / 0 new
Last post
darksnake
Offline
Joined: 1 year
Last seen: 12 months
Error after clean install 2.1 and 2.1.11

Hi guys,

After clean install i get a error running the program. See below my log file.
[ ]
[ ] WebGrab+Plus/w MDB & REX Postprocess -- version V2.1.11.0
[ ]
[ ] Jan van Straaten
[ ] Francis De Paemeleere
[ ]
[ ] thanks to Paul Weterings and all the contributing users
[ ] --------------------------------------------------------------------------------
[ ]
[ ] Job started at 27/09/2019 10:28:22
[ Debug ]
[ Debug ] Running on: Microsoft Windows NT 6.2.9200.0
[ Debug ] Environment: 4.0.30319.34014
[ Debug ]
[ Debug ] Loading timezone data
[ Debug ] Embedded timezones source: timezone.timezonesdata.txt
[ ] Job finished at 27/09/2019 10:28:22 done in 0s
[Critical]
Method not found: '!!0[] System.Array.Empty()'.
[Critical]
at WG.common.timezone.TimeZones.0.0(String 0)
at WG.common.timezone.TimeZones.0.LoadEmbeddedData(String 0)
at WG.common.timezone.TimeZones.constructor(String 0, String 1)
at WG.common.timezone.TimeZones..ctor()
at WG.common.timezone.TimeZones.0()
at WGconsole.G.1(String[] 0)
[Critical] Unhandled Exception
[Critical] For detailed info, see log file C:\Users\Administrator\AppData\Local\WebGrab+Plus\WebGrab++.log.txt
[Critical] Execution stopped

Does anyone know how to fix this?
Thanks

Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 11 hours

not sure what you did wrong,i just did a clean install on windows 10 and it worked fine.
I think your missing the timezone.dll file,it would be in the 2.1.11 update,check your C:\Program Files (x86)\WebGrab+Plus\bin directory to see if its there.

there should be these files present..

timezone.dll
logger.dll
xmltv.dll
WeGrab+Plus.exe
Site.Pack.Update.exe
changelog.txt

darksnake
Offline
Joined: 1 year
Last seen: 12 months

I also dont know what its about. Im installing this on windows server 2008 R2. Used another Server with same windows and get the same error.
The files you stated are in place see screenshot.

Tried to overwrite with v2.1.9 instead of 2.1.11 and get this now:
[ ]
[ ] WebGrab+Plus/w MDB & REX Postprocess -- version V2.1.9
[ ]
[ ] Jan van Straaten
[ ] Francis De Paemeleere
[ ]
[ ] thanks to Paul Weterings and all the contributing users
[ ] --------------------------------------------------------------------------------
[ ]
[ ] Job started at 27/09/2019 12:05:28
[ Debug ]
[ Debug ] Running on: Microsoft Windows NT 6.1.7601 Service Pack 1
[ Debug ] Environment: 4.0.30319.1
[ Debug ]
[ Debug ] Loading timezone data
[ Debug ] Embedded timezones source: timezone.timezonesdata.txt
[ Debug ] Reading config file: C:\Users\Administrator\AppData\Local\WebGrab+Plus\WebGrab++.config.xml
[ ] Job finished at 27/09/2019 12:05:28 done in 0s
[Critical] Unhandled Exception
[Critical]
Method not found: '!!0[] System.Array.Empty()'.
[Critical]
at WGconsole.F.1(String[] 0)
at WGconsole.F.0(String[] 0)
[Critical] For detailed info, see log file C:\Users\Administrator\AppData\Local\WebGrab+Plus\WebGrab++.log.txt
[Critical] Execution stopped

Attachments: 
Blackbear199
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 11 hours

upload your webgrab.config.xml
I think there may be a problem with it.

edit:
A quick search and the problem appears to be net framework,update it to the latest version.
https://support.microsoft.com/en-us/help/4054542/microsoft-net-framework...

darksnake
Offline
Joined: 1 year
Last seen: 12 months

netframe fixed it. thanks!

Ricky
Offline
Joined: 3 years
Last seen: 8 months

HI
i have before v2.1 working fine, on Win7
then i upgrade to this one v2.1.11
and i have the same error
i have the logger.dll
timezone.dll
xmlt.dll
any help
thanks

vykistwo
Offline
Joined: 10 months
Last seen: 10 months

Getting the same error on a Raspberry pi 4 , running Raspbian Buster after an update. Error i get is below:

[ ] Job started at 01/11/2019 14:19:25
[ Debug ]
[ Debug ] Running on: Unix 4.19.75.7
[ Debug ] Environment: 4.0.30319.17020
[ Debug ] Mono version: 2.11.4 (tarball Thu Mar 14 14:32:54 CDT 2013)
[ Debug ]
[ Debug ] Loading timezone data
[ Debug ] Embedded timezones source: timezone.timezonesdata.txt
[ ] Job finished at 01/11/2019 14:19:25 done in 0s
[Critical]

Method not found: 'System.Array.Empty'.
[Critical]

at WG.common.timezone.TimeZones+0.LoadEmbeddedData (System.String 0) [0x00000] in :0
at WG.common.timezone.TimeZones.constructor (System.String 0, System.String 1) [0x00000] in :0
at WG.common.timezone.TimeZones..ctor () [0x00000] in :0
[Critical] Unhandled Exception
[Critical] For detailed info, see log file /mnt/usb1/Tools/.wg++/./WebGrab++.log.txt
[Critical] Execution stopped

Can someone help?

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl