You are here

autoEPG reloaded

3 posts / 0 new
Last post
z0n1
Offline
Donator
Joined: 5 months
Last seen: 4 months
autoEPG reloaded

Hi all,

I was developing autoEPG [http://wiki.xmltv.org/index.php/AutoEpg] for years
unfortunately I lost the source code so the project was dead for years
after exchanging several messages with WG+P developer Idecided to revive the project

so here is the result
autoEPG is reborn, well kinda, with less features but works(mostly) with WG

use this version for testing ONLY!!!
make BACKUP of your WebGrab++.config.xml

I tested it and it woks, but I'm not responsible is you mess up your config file

what works:
- reading and saving settings, (most of them some still not iplemented)
- adding / removing channels in config file, very easy, select country, source and doubble click on channel to add it to your list (double click on the list removes it from config file
- start and run wg with output (start from program from with argument "grabb" it will start grabbing directly) example "autoepg reloaded.exe grabb"

planned:
- add all possible settings
- search for channel in list
- testing channel source
- site.ini auto-download
- decryption settings

not in near future:
- EPG viewer
- EPG manipulation (categories, remove unvanted lanuage, leave only one language in EPG, remove description, channel icons...
- translator ( the main function of original autoEPG
- maybe add more sources like XMLTV ...

any debuging, suggestions, help is appreciated , for the moment, please comments here, later I might resurrect autoEPG site

.... quick fix
extract zip and add reg.reg into registry, will fix it later ;)

also WebGrab++.config.xml for now must have the following elements

-----------------

<filename>save location</filename>
<license wg-username="user" registered-email="email" password="xxxxx">f</license>
<postprocess grab="yes" run="on"></postprocess>
<proxy>automatic</proxy>
<user-agent>random</user-agent>
<logging>off</logging>
<retry time-out="5">4</retry>
<skip>6,1</skip>
<timespan>2</timespan>
<update>s</update>

-------------------

...and of course with your data in it, due to bug this must be in the file on first run, after that you can update with autoEPG ;)

Attachments: 
mat8861
Offline
WG++ Team memberDonator
Joined: 5 years
Last seen: 4 hours

return error can't find path c:\users\Koen\appdata\webgrab+plus\siteini.pack if i hit continue it return error:
Le informazioni su come richiamare il debug JIT (Just-In-Time) anziché questa finestra
sono riportate in fondo al messaggio.

************** Testo dell'eccezione **************
System.NullReferenceException: Riferimento a un oggetto non impostato su un'istanza di oggetto.
in autoEPG_reloaded.Form1.Form1_Activated(Object sender, EventArgs e)
in System.Windows.Forms.Form.OnActivated(EventArgs e)
in System.Windows.Forms.Form.set_Active(Boolean value)
in System.Windows.Forms.Form.WmActivate(Message& m)
in System.Windows.Forms.Form.WndProc(Message& m)
in System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
in System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
in System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Assembly caricati **************
mscorlib
Versione assembly: 4.0.0.0
Versione Win32: 4.8.4180.0 built by: NET48REL1LAST_B
Base di codice: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
autoEPG reloaded
Versione assembly: 1.0.0.0
Versione Win32: 1.0.0.0
Base di codice: file:///C:/Users/mat88/AppData/Local/WebGrab+Plus/autoEPG%20reloaded.exe
----------------------------------------
Microsoft.VisualBasic
Versione assembly: 10.0.0.0
Versione Win32: 14.8.3752.0 built by: NET48REL1
Base di codice: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
-----------------------------

z0n1
Offline
Donator
Joined: 5 months
Last seen: 4 months

Thanks for the info, my bad, did nor replaced wg install path after debugging
;)

get the new zip, import registry file (a quick fix, will fix later )

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl