You are here

Astro - Malaysia - Not working / needs update?

10 posts / 0 new
Last post
pooloss
Offline
Joined: 4 years
Last seen: 2 years
Astro - Malaysia - Not working / needs update?

Hi Guys,

Astro Malaysia stopped working a few days ago.   I'm not sure if it requires an update?

I guess this error:

(   1/70  ) ASTRO.COM.MY -- chan. (xmltv_id=TLC) -- mode Incremental
i
Unable to update channel TLC
Generic syntax exception:
   message:
no index page data received from TLC
unable to update channel, try again later
Existing guide data restored!
(   1/70  ) ASTRO.COM.MY -- chan. (xmltv_id=FX HD) -- mode Incremental
i
Unable to update channel FX HD
Generic syntax exception:
   message:
no index page data received from FX HD
unable to update channel, try again later
Existing guide data restored!
(   1/70  ) ASTRO.COM.MY -- chan. (xmltv_id=Star World) -- mode Incremental
i
Unable to update channel Star World
Generic syntax exception:
   message:
no index page data received from Star World
unable to update channel, try again later
Existing guide data restored!
(   1/70  ) ASTRO.COM.MY -- chan. (xmltv_id=Diva HD) -- mode Incremental
i
Unable to update channel Diva HD
Generic syntax exception:
   message:
no index page data received from Diva HD
unable to update channel, try again later
Existing guide data restored!

 

Could you please take a look?

Thanks,

PL.

jksmurf
Offline
jksmurf's picture
Donator
Joined: 7 years
Last seen: 1 month
pooloss wrote:

Hi Guys,
Astro Malaysia stopped working a few days ago.   I'm not sure if it requires an update?

I tried to update the Channels but got this message.
I'd really appreciate it if some kind person could update the ini?

Thanks!

k.

[ ] WebGrab+Plus/w MDB & REX Postprocess -- version V2.1.11.0
[ ]
[ ] Jan van Straaten
[ ] Francis De Paemeleere
[ ]
[ ] thanks to Paul Weterings and all the contributing users
[ ] --------------------------------------------------------------------------------
[ ]
[ ] Job started at 14/09/2019 15:02:50
[ Debug ]
[ Debug ] Running on: Microsoft Windows NT 6.2.9200.0
[ Debug ] Environment: 4.0.30319.42000
[ Debug ]
[ Debug ] Loading timezone data
[ Debug ] Embedded timezones source: timezone.timezonesdata.txt
[ Debug ] Reading config file: C:\Users\Kristian\AppData\Local\WebGrab+Plus\WebGrab++.config.xml
[ Debug ]
[ Info ] found: C:\Users\Kristian\AppData\Local\WebGrab+Plus\siteini.user\astro.com.my.ini -- Revision 05
[Warning ]
[Warning ] !! SiteIni astro.com.my.ini in channelfile creation mode !!!
[Warning ]
[ Info ] input file C:\Utils\TVXB\XML\WebGrab\NowBBWebGrab.xml not found ... created a new one ...
[ Info ]
[ Info ]
[ Info ] i=index .=same c=change g=gab r=replace n=new
[ Info ]
[ Info ]
[ Info ] Group (0) :
[ Info ] update requested for - 1 - out of - 1 - channels for 1 day(s)
[ Debug ]
[ Info ] ( 1/1 ) ASTRO.COM.MY -- chan. (xmltv_id=dummy) -- mode Incremental
[Warning ] error downloading page: The remote name could not be resolved: 'ams-web-elb-378670955.ap-southeast-1.elb.amazonaws.com'
[Warning ] pausing 1 of 4 times for 5 seconds before re-try.
[Warning ] error downloading page: The remote name could not be resolved: 'ams-web-elb-378670955.ap-southeast-1.elb.amazonaws.com'
[Warning ] pausing 2 of 4 times for 10 seconds before re-try.

mat8861
Offline
WG++ Team memberDonator
Joined: 4 years
Last seen: 44 min

Working version (for donators) here : http://www.webgrabplus.com/forums/asia

jksmurf
Offline
jksmurf's picture
Donator
Joined: 7 years
Last seen: 1 month
mat8861 wrote:

Working version (for donators) here : http://www.webgrabplus.com/forums/asia

Thank you mat8661, I am a Donator (I have a badge show up when I log in), but I do not see anything at that link?

k.

bert
Offline
bert's picture
Donator
Joined: 1 year
Last seen: 2 days

I have a working INI for Astro Malaysia. The old ini pulls data from AWS (ams-web-elb-378670955.ap-southeast-1.elb.amazonaws.com), now, if you go to https://whatson.astro.com.my/channels/ and press F12, you see content are pulled from https://ams-api.astro.com.my/ams/v3/****

Use ams-api.astro.com.my for the url_index.

jksmurf
Offline
jksmurf's picture
Donator
Joined: 7 years
Last seen: 1 month
bert wrote:

I have a working INI for Astro Malaysia. The old ini pulls data from AWS (ams-web-elb-378670955.ap-southeast-1.elb.amazonaws.com), now, if you go to https://whatson.astro.com.my/channels/ and press F12, you see content are pulled from https://ams-api.astro.com.my/ams/v3/****
Use ams-api.astro.com.my for the url_index.

Thank you bert, will give it a try.
Much appreciated.

jksmurf
Offline
jksmurf's picture
Donator
Joined: 7 years
Last seen: 1 month
mat8861 wrote:

Working version (for donators) here : http://www.webgrabplus.com/forums/asia

Hi mat8661 - I looked at the site (I can now access it) but the ini seems to be out of date now as teh site has shifted to whatson.astro.com.my.

e.g. https://whatson.astro.com.my/channels/abc-australia/52/?cat=lifestyle&la...

Could it be updated for this please?

Thanks

k.

mat8861
Offline
WG++ Team memberDonator
Joined: 4 years
Last seen: 44 min

create a new channel list using update mode c Sample here: http://www.webgrabplus.com/documentation/configuration/sitechannelsxml:

james0baster
Offline
Joined: 4 months
Last seen: 2 months

I have able to grab the Astro EPG with small edit on the .ini file, below is my astro.com.my.ini

Quote:

site {url=astro.com.my|timezone=Asia/Kuala_Lumpur|maxdays=7|cultureinfo=en-GB|charset=UTF-8|titlematchfactor=90|episodesystem=xmltv_ns}
url_index{url|http://ams-api.astro.com.my/ams/v3/getEvents?periodStart=|urldate|:00:00:00&periodEnd=|urldate|:23:59:59&channelId=|channel|}
url_index.headers {customheader=Accept-Encoding=gzip,deflate}
urldate.format {datestring|yyy-MM-dd}
index_showsplit.scrub {regex||\{"eventID":.*?\]\},||}
index_start.scrub {regex||"displayDateTime":".*?(\d+:\d+:\d+)\.\d+||}
index_duration.scrub {regex||"displayDuration":"(\d+:\d+):\d+||}
index_title.scrub {single|"programmeTitle":"||","}
index_description.scrub {single|"shortSynopsis":"||","}
index_category.scrub {single|"genre":"||","}
index_category.scrub {single|"subGenre":"||","}
index_actor.scrub {single(separator=",")|"actors":"||","}
index_director.scrub {single(separator=",")|"directors":"||","}
index_producer.scrub {single|(separator=",")|"producers":"||","}
index_showicon.scrub {single|"epgEventImage":"||","}
index_episode.modify {substring(type=regex pattern="'S1' Ep'E1'""Ep'E1'")|'index_title' "S\d+\sEp\d+\|Ep\d+"}
index_title.modify {remove(type=regex)|\sS\d+\sEp\d+\|\sEp\d+}

Attachments: 
crazy_ku
Offline
Joined: 4 months
Last seen: 1 week

Why it always ignore the first show of 2nd, 3rd day in case I grab more than 1 day?
It done with every show except those 1st show.
Can you help to test it?

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl