You are here

EPG guide

35 posts / 0 new
Last post
Henry
Offline
Joined: 10 months
Last seen: 9 months
EPG guide

Hi
Can you please help me
I want to add DSTV to my Kodi EPG guide. I have a lot of info but I do not know what is relevant anymore since most of the posts on the forum is old and I do not know if the posts is guiding me in the right direction or not, I am using Kodi 18 on windows 10
I have attached a ZIP file with all I have done so far.

Thank you in advance

Henry

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

your ini files are old and dont work,u will have to se if someone will provider updated one.

Henry
Offline
Joined: 10 months
Last seen: 9 months

Thanks for the reply

This is the latest ini file that i could fined on the webgrabber plus web site, can you perhaps direct me to someone that have a updated ini file?

Henry
Offline
Joined: 10 months
Last seen: 9 months

or can someone perhaps explain to me how to create my own ini file from the Dstv tv guide

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month
Henry
Offline
Joined: 10 months
Last seen: 9 months

Thank you, but i am not up to date with all that is explained in the above mentioned documentation (this is my first time ever trying to do something lick this, and i did not expect it to be so involved)
In the webgrabber down lode we are supplied with a working example of all the files.
Point being
I do not know how to use the developer tools on a web browser and i do not know how to see the relevant information in the developers tool for the web browser to be able to do the above mentioned.
Perhaps if i can be guided so that i can get the epg data from the developer tools and just copy and past it in too the ini file that i have?

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

ur idea wont work for too many reasons to even try to explain.
i'll give u one..
so ur gonna devote time every day to copy the data from the site to a file and make sure you do it correctly everytime without making a mistake.

just in that statement there are many place where something can go wrong...

Henry
Offline
Joined: 10 months
Last seen: 9 months

Is there any other viable solution for me?

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

tvpassport

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

oops,that wont work for south africa.lol
its usa/canada..

Henry
Offline
Joined: 10 months
Last seen: 9 months

Thank you for the effort but it still did not work.

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

well ur not following the insstructions in the txt file right..

roup (0) :
update requested for - 1 - out of - 1 - channels for 1 day(s)
( 1/1 ) DSTV.COM -- chan. (xmltv_id=M-Net) -- mode Force
innnnnnnnnnnnnnnnnn
0.49 sec/update

are u getting a error?
if so what error?

Henry
Offline
Joined: 10 months
Last seen: 9 months

I am sorry but i am so confused at this point. I have run my setup.
pleas fined my zip attached.

Henry
Offline
Joined: 10 months
Last seen: 9 months

I have changed my time zone to Africa/Johannesburg after reading the text again,
but it still states no shows in index
I am all so using internet explorer instead of chrome to create my cookies folder, dos that matter

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

upload ur log file.

Henry
Offline
Joined: 10 months
Last seen: 9 months

uploaded

Attachments: 
Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

first update to wg 2.1.5
http://webgrabplus.com/download/sw/v2.1.5

try again.
if it still dont work upload ur cookie file.

Henry
Offline
Joined: 10 months
Last seen: 9 months

I have upgraded to v/2.1.5
attached is my cookie file, the original one and the one that the webgabber made

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

ur cookie file looks fine.
did u create ur channel list using this cookie?

zip ur cookie,channel.xml and post it so i can see if i can duplicate ur error.

Henry
Offline
Joined: 10 months
Last seen: 9 months

zipped file attached
i do not now how to create a channel list, i copied it from the list supplied with the install of webgrabber

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

thats ur prob then,follow directions in the txt file...

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

supplied ch list might be for nigeria or some other country,u need to create ur own using ur cookie file.
just do all the steps in txt file.

Henry
Offline
Joined: 10 months
Last seen: 9 months

oo oky, i misunderstood you question.
i did go too the website and i did click on the right flag and created the cookies text file according to that instructions.

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

but u didnt do the important part..
create a channel list with ur selections.
this is where the cookie is used as it has the info.

Henry
Offline
Joined: 10 months
Last seen: 9 months

Oky i get it, can you perhaps help me with the following part

(channels.xml creation section and enable only this section..
** ##### COUNTRY CODE FILE CREATION (only to create the xxx-channel.xml file)

how do i only enable or disable one section?

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

do the steps
when u complete the first,disable it(add the * to beginning of all line)
copy the channel line created in dstv.com.channels.xml
to ur wg config
and enable the next step
just as the txt file says...

Henry
Offline
Joined: 10 months
Last seen: 9 months

thank you.
i will give it a go tomorrow.

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

ur doing the same thing u wud do on the site..

1.select country
2. select package
3.view channels

u have todo each manually in webgrab,so if u mess up step 1 then step 2 and 3 will surely not work...

Henry
Offline
Joined: 10 months
Last seen: 9 months

oky, i have deleted every ting and rerun the setup after a fresh install of wg V2.1.5.
i think that i got all the steps correctly.
the log file looks different than before, so something did change but the error still states no shows in indexpage
i will attache the zip of my current setup

i must say this program is not very user friendly for dummies lick me.

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

what did u do with the ini i gave u?
ur not using it,ur using the old one...

[ Info ] found: C:\Users\Henry\AppData\Local\WebGrab+Plus\dstv.com.ini -- Revision 05

one i gave u is Revision 8

Henry
Offline
Joined: 10 months
Last seen: 9 months

sorry i have mist that, i have inserted RV 8

Blackbear199
Offline
Donator
Joined: 4 years
Last seen: 1 month

your ur own worste enemy.
u dont need any help to get messed up.

your using a channel list that was created with the revison 5 ini.
redo it again with revision 8 ini as the site_id="xxx" info is different.

dont ever assume that the channels.xml never changes,it does....all the time.
your cookie file is fine(it works for me).

Henry
Offline
Joined: 10 months
Last seen: 9 months

lol.

this is all just too much for me, most of the time i am lost.
when i think that i am doing tings right i still mes up.
i assume that you now that i am using the kodi wg add on to do this.
is there a possibility that you can help me over team viewer?

Henry
Offline
Joined: 10 months
Last seen: 9 months

this is my latest attempt attached

Stoff
Offline
Joined: 5 months
Last seen: 4 months

Works great!!!!!

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl