You are here

uk.sky.com

45 posts / 0 new
Last post
KleMC
Offline
Donator
Joined: 5 years
Last seen: 4 months
uk.sky.com

Hi, I am using v2.1. Since a few weeks, the show title has a (?) at the end and there is no description anymore. Can you please look into an upgrade?

 

many thanks and keep up the great work,

KleMC

Attachments: 
moshoodo123
Offline
Joined: 1 year
Last seen: 2 months

same here

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours

 if i win the lotto tonight i will post the ini.

if i dont well...

ur SOL

btw this is a one time offer,if i win next week it dont count.

freddy12
Offline
Donator
Joined: 2 years
Last seen: 4 months

how big of a lotto we talking here devil

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours

it doesnt matter when one didnt win...

 

pielord
Offline
Donator
Joined: 5 months
Last seen: 2 months

Hi all

Mainly @Blackbear199

I'm trying to modify the uk-sky.com.ini to remove the (?) error, no luck so far, am I right in presuming the issue is with these lines?

index_urlshow.modify {addstart('index_title' not~ "..programmes start at")|http://tv.sky.com/programme/detail/'index_temp_1'}
index_urlshow.modify {addend(not "")|/'{single(include=first)|:"||",|",}'}
index_urlshow.headers {customheader=Accept-Encoding=gzip,deflate}

or is the issue deeper? perhaps with the parsing using when referencing index_temp1?

I'm not here to leech mate and I've donated and I share your frustrations with folks just leeching and selling, it's not cool.

 

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours

I'm trying to modify the uk-sky.com.ini to remove the (?) error, no luck so far, am I right in presuming the issue is with these lines?

yes

index_urlshow.modify {addstart('index_title' not~ "..programmes start at")|http://tv.sky.com/programme/detail/'index_temp_1'}
index_urlshow.modify {addend(not "")|/'{single(include=first)|:"||",|",}'}
index_urlshow.headers {customheader=Accept-Encoding=gzip,deflate}

or is the issue deeper? perhaps with the parsing using when referencing index_temp1?

what makes you think the new site uses the same url or format?

this tells me your 100% guessing.

use ur browser dev tools and click on a program to view its details and see what happens.

i gurantee u willl never get it fixed assuming.

 

 

pielord
Offline
Donator
Joined: 5 months
Last seen: 2 months

Apologies for assuming then, was hoping for a little help with if I was on the right path, as I said I'm new to this....

Now looking at https://production-retriever.h*******pp.com as the url and seeing how it formats the data.....

 

Blackbear199 wrote:

I'm trying to modify the uk-sky.com.ini to remove the (?) error, no luck so far, am I right in presuming the issue is with these lines?

yes

index_urlshow.modify {addstart('index_title' not~ "..programmes start at")|http://tv.sky.com/programme/detail/'index_temp_1'}
index_urlshow.modify {addend(not "")|/'{single(include=first)|:"||",|",}'}
index_urlshow.headers {customheader=Accept-Encoding=gzip,deflate}

or is the issue deeper? perhaps with the parsing using when referencing index_temp1?

what makes you think the new site uses the same url or format?

this tells me your 100% guessing.

use ur browser dev tools and click on a program to view its details and see what happens.

i gurantee u willl never get it fixed assuming.

 

 

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours

now that u got that far,the next step is deciding if you even need it..

is there any information there thats not on the index page?

if not then you can remove the index_urlshow and anything related to it(like all details elements).

if you think its needed then you need to figure out how to format it correctly and update details elements.

dont assume anything just because the old site has this or that doesnt mean the new has it or vice versa.

inspect the data and decide for yourself what to do.

 

 

 

pielord
Offline
Donator
Joined: 5 months
Last seen: 2 months

I kinda get you and I can see all the info needed is there, we're you joking when you said there was a manual? Or does such a thing exist? If so where?

 

Blackbear199 wrote:

now that u got that far,the next step is deciding if you even need it..

is there any information there thats not on the index page?

if not then you can remove the index_urlshow and anything related to it(like all details elements).

if you think its needed then you need to figure out how to format it correctly and update details elements.

dont assume anything just because the old site has this or that doesnt mean the new has it or vice versa.

inspect the data and decide for yourself what to do.

 

 

 

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours
pielord
Offline
Donator
Joined: 5 months
Last seen: 2 months

Thank you

and BOOM!!!!

Got it working with all I need :-)

Blackbear199 wrote:

wg manual?

http://www.webgrabplus.com/sites/default/files/download/documentation/Ma...

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours

wasnt so hard now was it.

now u can see if u can figure out how to extract other elements from the info(if u want them separated) like season/episode number,subtitle,ect

 

pielord
Offline
Donator
Joined: 5 months
Last seen: 2 months

Nope, will expand on it but I think I may find another source site use now I have the gist of it.

For now this is working exactly how I want it and my god it's quicker :-)

Blackbear199 wrote:

wasnt so hard now was it.

now u can see if u can figure out how to extract other elements from the info(if u want them separated) like season/episode number,subtitle,ect

 

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours

of course its quicker..

soon as u add a details page the speed drops by 50% in most cases.

 

 

pielord
Offline
Donator
Joined: 5 months
Last seen: 2 months

I've added basic details for now, just filtering through what I need.

Out of interest what tools are you using for the capture? Fiddler? Tshark?

Blackbear199 wrote:

of course its quicker..

soon as u add a details page the speed drops by 50% in most cases.

 

 

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours

i told you above.

every web browser has built in developer tools.

i use chromium.that all you need..

 

pielord
Offline
Donator
Joined: 5 months
Last seen: 2 months

I tried the dev tools you mentioned, however found it far easier with tools like 'fiddler' where I was able to follow specific strings, made very light work of it.

KleMC
Offline
Donator
Joined: 5 years
Last seen: 4 months

Thanks guys, I really appreciate your efforts! Just donated, so should have a badge soon :)

cheers,

KleMC

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours

use whatever  your comfortable with.

i downloaded this(works on linux also).does as you say but your getting all network traffic which i could find some use for so thks.

 

pielord
Offline
Donator
Joined: 5 months
Last seen: 2 months
Blackbear199 wrote:

use whatever  your comfortable with.

i downloaded this(works on linux also).does as you say but your getting all network traffic which i could find some use for so thks.

Did you forget a link mate?

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours
pielord wrote:

Blackbear199 wrote:

use whatever  your comfortable with.

i downloaded this(works on linux also).does as you say but your getting all network traffic which i could find some use for so thks.

Did you forget a link mate?

i was referring to fiddler.

 

KleMC
Offline
Donator
Joined: 5 years
Last seen: 4 months

Guys, I have now switched to radiotimes where all the channels seem to work. 

thanks again for your support,

KleMC

kiranjoban
Offline
Donator
Joined: 2 years
Last seen: 5 days

can anyone upload skyuk ini please

harryporter
Offline
Joined: 2 months
Last seen: 2 months

Please upload fixed ini file,

Thanks

Fringe
Offline
Joined: 11 months
Last seen: 2 months

I'd like to request the updated ini for sky UK please, seeing comments about it working but no-ones uploaded anything :(

mat8861
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 43 min
Fringe wrote:

I'd like to request the updated ini for sky UK please, seeing comments about it working but no-ones uploaded anything :(

Passion to do site.ini for free ended when someone started abusing.
That said, it takes time and efforts to create a site.ini and in my personal opinion, other then (first) contribute to this great forum, should also somehow contribute to the creators of the site inis for the work done. Otherwise you can use free epg sources like Rytec or Kodiepg and have fun anyway. Again is my personal opinion.

Fringe
Offline
Joined: 11 months
Last seen: 2 months
mat8861 wrote:

Fringe wrote:
I'd like to request the updated ini for sky UK please, seeing comments about it working but no-ones uploaded anything :(

Passion to do site.ini for free ended when someone started abusing.
That said, it takes time and efforts to create a site.ini and in my personal opinion, other then (first) contribute to this great forum, should also somehow contribute to the creators of the site inis for the work done. Otherwise you can use free epg sources like Rytec or Kodiepg and have fun anyway. Again is my personal opinion.

I never "abused" anything and I do try and learn....So what your saying is those who don't contribute don't get help? I'd love to be able to sort things myself but having spent hours just mastering the basics as looking at lines and lines of code isn't easy for me as I'm dsylex and so I struggle.

I never wanted to use free servers like Rytec etc as I like to do my own hard work this is why I learned Webgrab, well off to Rytec it is then as I know and have tried to fix this ini myself and ito not something I can do so thats why I posted in the "request" section.

Thanks for letting me know anyway.

gillmacca
Offline
Joined: 1 year
Last seen: 1 week

I personally would be more than willing to contribute to someone, if I could get a fully working sky epg

encode
Offline
Donator
Joined: 7 months
Last seen: 1 month

I have a working version but has all the problems that started with the old site.

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours

more details on these probs?

encode
Offline
Donator
Joined: 7 months
Last seen: 1 month

timeout is set to 40>4

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours

shud be fine.without seeing ur ini i cannot comment any more.
are u using the new web address?
hint,its index page only...

encode
Offline
Donator
Joined: 7 months
Last seen: 1 month

ah i see, thanks for your help :)

encode
Offline
Donator
Joined: 7 months
Last seen: 1 month

I would share but it will get abused

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours

well i for one dont need it as i had it done long time ago...
but ur thinking is good.

Fringe
Offline
Joined: 11 months
Last seen: 2 months

I'm trying to get this updated, I figured I'd start with the bottom of the ini to grab the channels. I have updated the URL but its not working, no surprise really but do I atleast have the right URL? Am I heading in the right direction?

** _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
** ##### CHANNEL FILE CREATION (only to create the xxx-channel.xml file)
**
url_index{url|http://skyplustv.sky.com/tv-guide#/tvlistings-proxy/TVListingsProxy/init...}
index_site_channel.scrub {multi|title|:"|",|",}
index_site_id.scrub {multi|channelid|:"|",|",}
index_site_channel.modify {replace|\'|}
(scope.range {(channellist)|end
(index_site_id.modify {cleanup(removeduplicates=equal,100 link="index_site_channel")}
end_scope
** @auto_xml_channel_end

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours

since u didnt seem to understand my last post regarding using the new site urls.
if we were playing baseball you wouldnt be on the same continent as me..

Fringe
Offline
Joined: 11 months
Last seen: 2 months
Blackbear199 wrote:

since u didnt seem to understand my last post regarding using the new site urls.
if we were playing baseball you wouldnt be on the same continent as me..

What last post using URL's??? I requested a updated ini in the request section of the forum and was told that no-one will share so I'm trying to do this myself, insulting me by saying I'm not even on the same continent as you just because you know how to do this doesn't mean it comes as easy to everyone else. I'm trying and just becuase I have learning difficulties DOES NOT give you the right to treat me like some F******KING IDIOT!!!!

Atleast I'm trying, it might take me longer and I might need more help or things explaining, I might not even get it BUT i will give it ago.

Fringe
Offline
Joined: 11 months
Last seen: 2 months

Right for anyone willing to help I hope this is going in the right direction :)

Using this

** _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
** ##### CHANNEL FILE CREATION (only to create the xxx-channel.xml file)
**
url_index{url|http://epgservices.sky.com/tvlistings-proxy/TVListingsProxy/init.json}
index_site_channel.scrub {multi|title|:"|",|",}
index_site_id.scrub {multi|channelid|:"|",|",}
index_site_channel.modify {replace|\'|}
scope.range {(channellist)|end}
index_site_id.modify {cleanup(removeduplicates=equal,100 link="index_site_channel")}
end_scope
** @auto_xml_channel_end

I was able to make a new channel list (attached) so I hope I'm getting something correct, lol, so the next step is the main ini content. Now am I correct in thinking that I need to replace

index_urlshow {url|http://tv.sky.com/programme/detail/|channelid":"||",}

with

index_urlshow {url|http://epgservices.sky.com/programme/detail/|channelid":"||",}

and also I am OK to leave this part of the ini in place as is?

site {url=tv.sky.com|timezone=UTC|maxdays=7|cultureinfo=en-GB|charset=ISO-8859-1|episodesystem=onscreen|ratingsystem=UK}

Its the url=tv.sky.com I think is just for naming not actualy the URL data is pulled from?

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours

if u were using ur developer tools in your web browser you would see what the correct urls are to use.
google can answer how todo this.
if you think i am going to tell you then forget it,u learn nothing by being spoon fed.
this will be the last of my help,have a noice day.

Fringe
Offline
Joined: 11 months
Last seen: 2 months
Blackbear199 wrote:

if u were using ur developer tools in your web browser you would see what the correct urls are to use.
google can answer how todo this.
if you think i am going to tell you then forget it,u learn nothing by being spoon fed.
this will be the last of my help,have a noice day.

@Blackbear199

I'm not asking to be spoon fed, I was asking for support on a support forum! Not everyone is as "smart" as you and its hard to learn with comments like "not on the same continent" and with so little info posted its hard to understand so I asked for HELP! I did not ask to be "spoon fed" just pointing in the right direction, some actual support...

Would it have really been so bad for you to say "look at my post about using a browser web dev tools" also "start with this URL...... and see what its telling you" Also would it have been so bad for you to say "If your unsure of what the web dev tools is telling you, google has loads of posts to help", some actual SUPPORT in a support forum!!!!

Don't worry you have shown what little regard you have for those who don't know how to do this as well as you. What a shame you have also shown anyone new looking for help that this is NOT the place to get it and that they should just bugger off to google. Its bad attitudes like yours that ruin support forums... we all need a help hand learning something new, just becuase you don't need help with webgrab doesn't give you the right to be so rude!

BTW... I might have learning difficulties but I can spell so HAVE A NICE DAY

Blackbear199
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 6 hours

i guess u think i woke up one day and kew everything abt webgrab and howto create ini's?
if so ur 300% wrong,i knew nothing,when i got stuck and couldnt figure it out i asked for help(all the posts are here..somewhere).
98% of what i know was learned the hard way..by trial and error.

i told you where to look,if you dont want todo it then thats fine.dont complain because someone else wont do it for you.

Fringe
Offline
Joined: 11 months
Last seen: 2 months
Blackbear199 wrote:

since u didnt seem to understand my last post regarding using the new site urls.
if we were playing baseball you wouldnt be on the same continent as me..

@Blackbear199

That was your first comment to me! you didn't make any previous comment about URL's to me so how can you say I didn't understand, in what part of that comment is there any help????

Maybe you should stop, actually look at the answers you provided when I asked and see which part was in anyway helpful? WHAT URL??????

I am trying to figure it out too, but all I get from you is a load of abuse and comments regarding previous comments you never made. I don't want someone to do it for me I just want to know if what I posted was going in the correct direction, if not then just tell me its wrong so I can look for the correct answer!!!!

mat8861
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 43 min

Fringe, you have to start reading the bible, aka the webgrab documentation 2.1.
If you do not read that, it will be difficult, the url is there, Blackbear199 is not hiding it and it is not a secret, so no need to tell you is http://xxxx , you need (if you want to learn) to find it by your own and understand how to get it working.
Webgrab is a program where you need to understand from the beginning to the end and work on site.ini not only once but many many times, to get one working. It took me 2 years (i didn't know anything) and i do not how many site.ini i made or reviewed, or even just run trying to understand how it all works, I still think i know 60% of webgrab. That's what you need to do, if you want to learn.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl