You are here

Plus.es (Movistar+), channels that WG+ can't get info

38 posts / 0 new
Last post
Darzlir
Offline
Donator
Joined: 1 year
Last seen: 1 week
Plus.es (Movistar+), channels that WG+ can't get info

I have decided to move the thread to a correct site, to try to find a solution to this channels.

Apparently there are channels that although the information is irrelevant or useless, it would be good to no empty spaces wherever it will be used (Kodi, TVH ...)

Sky News
http://www.movistarplus.es/canal/sky-news?id=SKYNW

RT France
http://www.movistarplus.es/canal/rt-francia-hd?id=RTFRHD

Arirang
http://www.movistarplus.es/canal/nhk-world-tv?id=NHK

NHK World
http://www.movistarplus.es/canal/arirang-tv?id=ARIRAN

In these cases, I am currently using the fixed.ini with a 24-hour schedule, with the channel information. Simple and effective.

The problem is other channels, some with a 24 hours others with eventual programming, which wg + can not get the information. On these channels, I would like to find a solution. if there is an event that wants to see and record I would like not to have to look for it on the web...

Channels like:

LaLiga BAR
http://www.movistarplus.es/canal/laligatvbar?id=LIGBAR

Multideporte 2 & 3
http://www.movistarplus.es/canal/multideporte-2?id=USOP2
http://www.movistarplus.es/canal/multideporte-3?id=USOP3

Canal Extremadura SAT
http://www.movistarplus.es/canal/canal-extremadura-sat?id=EXTREM

I think it is not impossible but I do not know what I have to edit or what to do to make it work, I'm using the latest version of plus.es.ini (Revision 13), but some channels that both mat8861 and Blackbear199 showed in the post, they have EPG (even if it's useless), I can't get it :\

thepableras
Offline
Donator
Joined: 1 year
Last seen: 1 month

Same problem here. Looks weird!

mat8861
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 27 min

if you would have checked the website, you would have noticed there is no epg

thepableras
Offline
Donator
Joined: 1 year
Last seen: 1 month
mat8861 wrote:

if you would have checked the website, you would have noticed there is no epg

Are you sure? Try grab this

You wont get any epg

http://www.movistarplus.es/canal/multideporte-2?id=USOP2

thepableras
Offline
Donator
Joined: 1 year
Last seen: 1 month

Could you share your .ini?

Cant here (attached log)

mat8861
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 27 min

from what i see the channel have no epg. Now if provider puts only one show at 6.00 what can you do ?

Attachments: 
mat8861
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 27 min

yes, but that would be...useless, i sleep at that time :) I made some changes, like subtitle for multideporte channels (no urlshow), seems to run faster also, but i still have some mismatch on episodes on channel Alquiler 4 and 5. Do you have the same ?

Attachments: 
Darzlir
Offline
Donator
Joined: 1 year
Last seen: 1 week

I was being stupid..., because the EPG of these channels have more than 12 hours and I was doing wrong the line of the time at WebGrab++.config.xml file.

Now I have another problem and that is the epg capture process, it does not set the end time, only start time, so it captures that "the show" starting at 6am and ending at 6am of the same day ...

[ Info ] ( 2/5 ) PLUS.ES -- chan. (xmltv_id=Sky News) -- mode Incremental
[ Debug ] skipped : last show, no next startime to use as stop

How could I solve it?

Then another channel problem :(, in the log and in the "prueba.xml" appears, the LaLigaTVBAR, which does not indicate any show, when there is ...

http://www.movistarplus.es/canal/laligatvbar?id=LIGBAR

thepableras
Offline
Donator
Joined: 1 year
Last seen: 1 month
mat8861 wrote:

yes, but that would be...useless, i sleep at that time :) I made some changes, like subtitle for multideporte channels (no urlshow), seems to run faster also, but i still have some mismatch on episodes on channel Alquiler 4 and 5. Do you have the same ?

Could you share this ini? ;)

Darzlir
Offline
Donator
Joined: 1 year
Last seen: 1 week

I have edited the OP and moved to this forum because I think it is more appropriate

Ps. made donation :)

mat8861
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 27 min
thepableras wrote:

mat8861 wrote:
yes, but that would be...useless, i sleep at that time :) I made some changes, like subtitle for multideporte channels (no urlshow), seems to run faster also, but i still have some mismatch on episodes on channel Alquiler 4 and 5. Do you have the same ?

Could you share this ini? ;)

I have not fully tested....so let me know if it is ok.

Update 1sep2018

Attachments: 
Darzlir
Offline
Donator
Joined: 1 year
Last seen: 1 week

Thank you mat8861, As soon as I can download it, I'll try it. I made the donation a few minutes ago

thepableras
Offline
Donator
Joined: 1 year
Last seen: 1 month

I have detected a bad behavior

http://www.movistarplus.es/programacion-tv/2018-08-15/?canal=CPCOLE&v=json
http://www.movistarplus.es/programacion-tv/2018-08-14/?canal=CPCOLE&v=json

When you download several days the last show on day 1 is the same as first show of day 2, so webgrab ends up creating one more day and jumping (losing all the information from day 2) to the next (3rd day). Is there any way to fix this?

mat8861
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 27 min

fixed see the post above

andresmejias
Offline
Joined: 3 years
Last seen: 5 months

Hi,

Sorry, what is the password for the zip file?

Thanks for your work!!

doublevision
Offline
Donator
Joined: 5 months
Last seen: 3 months

op

Darzlir
Offline
Donator
Joined: 1 year
Last seen: 1 week

Good morning!

I have already done some tests with the mat8861 .ini and here is my little feedback

Channels like LaLiga BAR, Multideporte 2 & 3 or Canal Extremadura SAT, are solved.

Channels like Sky News, RT France, Arirang or NHK World, still don't work, finally I will do something with the .fixed.ini to not have the empty space at EPG.

Other things to be fixed, are:

-Movistar Golf doesn't work, the channel id is "Golf+" with the .ini "plus.es" works fine, but with the "movistarplus.es" of mat8861 no (attached log and xml). I think it can be some configuration, because the channel exists, however the web is not "Golf+" is "Golf% 2B" http://www.movistarplus.es/canal/movistar-golf?id=GOLF%2B. Maybe some configuration does not allow signs and does not take well the url?

-The covers of the events:

I have changed
showicon.modify {addstart (not "") | http: //comunicacion.movistarplus.es}

by (used in plus.es)
showicon.scrub {single | div class = "cover"> | img src = "|" | alt} [adding "<" before of div and img]

I guess at http://comunicacion.movistarplus.es dont exist the covers and that's why they did not appear. Now in the XML I have this

icon src="http://www.movistarplus.es/recorte/n/caratula4/M870889V1564848" />
episode-num system="onscreen">S8 E20

-Last thing is I have noticed an increase in time to grab. I think it's because WG + makes a lot of changes when is grabbing, even when there aren't or there are not so many, I've been checking it manually, especially in series channels (attached png).

That's all, for now :)

mat8861
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 27 min

Above new version. For the changes that is because you use incremental mode, so if something change on the site webgrab will obviously report it as a change. For sky news and the others, if there is no epg on this site not much to do, other then grabbing from other sites.

Darzlir
Offline
Donator
Joined: 1 year
Last seen: 1 week

Hi mat, for now everything is correct. Only sometimes I see a "problem".

On Sunday movistar starts a new sports channel "#Vamos", its epg is this
http://www.movistarplus.es/canal/vamos?id=VAMOSD

I create a new xml file. For today it generates the programming of Sunday, because the actual programming of today, tomorrow and the day after tomorrow has the same problem with the other channels. (From 06:00 to 06:00) and WG+ ignore these elements, the following ones of Sunday when its emission begins, places them for today.

This has been happening since there is programming, a couple of days ago. It will not be a problem because from Sunday onwards there will be correct programming. But I think that for the new extra channels (M. Deportes 1-2-3-4-5-6...) that they have created, the same thing can happen. Let there be one or two events on a Sunday and would be scheduled for the day that updated the xml like I describe for "#Vamos".

Attachments: 
Darzlir
Offline
Donator
Joined: 1 year
Last seen: 1 week

Thanks Blackbear199! :) If you want close this post...

thepableras
Offline
Donator
Joined: 1 year
Last seen: 1 month

Sometimes the duration is incorrect, which occasionally the guide was not selected for the actual day as shown below:

[ Debug ] Debugging information SiteIni
[ Debug ] Element: INDEX_START
[ Debug ] html source written to : C:\ProgramData\ServerCare\WebGrab\html.source.htm
[ Debug ] scrub strings:
[ Debug ] type & arguments : single(debug)
[ Debug ] blockstart (bs): "HORA_INICIO":"
[ Debug ] elementstart (es):
[ Debug ] elementend (ee): "
[ Debug ] blockend (be): "
[ Debug ]
[ Debug ] Separated html block(s), number of blocks = 1
[ Debug ] ----------begin--block----------
[ Debug ] 08:00"
[ Debug ] ----------end----block----------
[ Debug ]
[ Debug ] Separated Element(s) (es) applied
[ Debug ] ----------begin--element----------
[ Debug ] 08:00"
[ Debug ] ----------end----element----------
[ Debug ]
[ Debug ] Separated Element(s) (es) and (ee) applied of block 0
[ Debug ] ----------begin--element----------
[ Debug ] 08:00
[ Debug ] ----------end----element----------
[ Debug ]
[ Debug ] Elements , type single applied
[ Debug ] ----------begin--element----------
[ Debug ] 08:00
[ Debug ] ----------end----element----------
[ Debug ] Converted to:
20/09/2018 8:00:00
[ Debug ] Debugging information SiteIni
[ Debug ] Element: INDEX_START
[ Debug ] html source written to : C:\ProgramData\ServerCare\WebGrab\html.source.htm
[ Debug ] scrub strings:
[ Debug ] type & arguments : single(debug)
[ Debug ] blockstart (bs): "HORA_INICIO":"
[ Debug ] elementstart (es):
[ Debug ] elementend (ee): "
[ Debug ] blockend (be): "
[ Debug ] xmltv starttime string:
20180921080000 +0200
[ Debug ] Debugging information SiteIni
[ Debug ] Element: INDEX_START
[ Debug ] html source written to : C:\ProgramData\ServerCare\WebGrab\html.source.htm
[ Debug ] scrub strings:
[ Debug ] type & arguments : single(debug)
[ Debug ] blockstart (bs): "HORA_INICIO":"
[ Debug ] elementstart (es):
[ Debug ] elementend (ee): "
[ Debug ] blockend (be): "
[ Debug ]
[ Debug ] Separated html block(s), number of blocks = 1
[ Debug ] ----------begin--block----------
[ Debug ] 09:30"
[ Debug ] ----------end----block----------
[ Debug ]
[ Debug ] Separated Element(s) (es) applied
[ Debug ] ----------begin--element----------
[ Debug ] 09:30"
[ Debug ] ----------end----element----------
[ Debug ]
[ Debug ] Separated Element(s) (es) and (ee) applied of block 0
[ Debug ] ----------begin--element----------
[ Debug ] 09:30
[ Debug ] ----------end----element----------
[ Debug ]
[ Debug ] Elements , type single applied
[ Debug ] ----------begin--element----------
[ Debug ] 09:30
[ Debug ] ----------end----element----------
[ Debug ] Converted to:
20/09/2018 9:30:00
[ Debug ] Debugging information SiteIni
[ Debug ] Element: INDEX_START
[ Debug ] html source written to : C:\ProgramData\ServerCare\WebGrab\html.source.htm
[ Debug ] scrub strings:
[ Debug ] type & arguments : single(debug)
[ Debug ] blockstart (bs): "HORA_INICIO":"
[ Debug ] elementstart (es):
[ Debug ] elementend (ee): "
[ Debug ] blockend (be): "
[ Debug ] xmltv starttime string:
20180921093000 +0200
[ Debug ] Debugging information SiteIni
[ Debug ] Element: INDEX_START
[ Debug ] html source written to : C:\ProgramData\ServerCare\WebGrab\html.source.htm
[ Debug ] scrub strings:
[ Debug ] type & arguments : single(debug)
[ Debug ] blockstart (bs): "HORA_INICIO":"
[ Debug ] elementstart (es):
[ Debug ] elementend (ee): "
[ Debug ] blockend (be): "
[ Debug ]
[ Debug ] Separated html block(s), number of blocks = 1
[ Debug ] ----------begin--block----------
[ Debug ] 09:45"
[ Debug ] ----------end----block----------
[ Debug ]
[ Debug ] Separated Element(s) (es) applied
[ Debug ] ----------begin--element----------
[ Debug ] 09:45"
[ Debug ] ----------end----element----------
[ Debug ]
[ Debug ] Separated Element(s) (es) and (ee) applied of block 0
[ Debug ] ----------begin--element----------
[ Debug ] 09:45
[ Debug ] ----------end----element----------
[ Debug ]
[ Debug ] Elements , type single applied
[ Debug ] ----------begin--element----------
[ Debug ] 09:45
[ Debug ] ----------end----element----------
[ Debug ] Converted to:
20/09/2018 9:45:00

---------------> Why 08:00 is 21/09 when before and after we are on 20/09 ? Looks ugly.

I would like to always use index_stop and when index_start equals index_stop, only in that case using index_duration.

I have tried it in the following way but I am not able to make it work.

index_start.scrub {single|"HORA_INICIO":"||"|"}
index_temp_8.scrub {single|"DURACION":||,|,}
index_temp_9.scrub {single|"HORA_FIN":"||"|"}
index_stop.modify {set('index_temp_9' not 'index_start')|'index_temp_9'}
index_duration.modify {set('index_temp_9' 'index_start')|'index_temp_8'}

thepableras
Offline
Donator
Joined: 1 year
Last seen: 1 month

Try grabbing id "MDISNE"
You will see the problem on the guide (using your .ini)

P.S.: I do not rule out that it could be a specific problem of json today.

That is so strange
[ Debug ] xmltv starttime string:
20180921080000 +0200

That mistake conversion.

Ending of the show should be at 20/09 08:00 not 21/09

thepableras
Offline
Donator
Joined: 1 year
Last seen: 1 month

I found the problem, duration of this show:

"Cars 2"
Duration: 103
Start time: "04:52"

"Los Teleñecos en cuentos de Navidad"
Start time: "06:34" <---------------------

Is not correct, it is 1 minute ahead of next start show time.

04:52 + 103 = 06:35

--------------------

I dont think there is any solution for this. What do you think?

user2you
Offline
Donator
Joined: 3 months
Last seen: 3 months

I've done the donation this morning. Where can I find the donator section once I get the donator badge from the administrator?

Thanks.

kvanc
Offline
WG++ Team memberDonator
Joined: 12 months
Last seen: 26 min

Click the forum page and go down, you will see

user2you
Offline
Donator
Joined: 3 months
Last seen: 3 months

Thank you, but where can I get the files you are talking about in this post?

kvanc
Offline
WG++ Team memberDonator
Joined: 12 months
Last seen: 26 min

You will see regions and topics with name of sites when u get ur badge

thepableras
Offline
Donator
Joined: 1 year
Last seen: 1 month

I have detected that with this .ini (version 15) although the shows are downloaded correctly first time they are never updated. If the code is obtained for a long number of days and then it is updated the programs never changes their name (when website did it).

I encourage you to download my .xml and try to update. Many shows are NOT updated (those who do not have time changes) to the new programming (title) or description, etc ...

For example;

start="20181029005000 +0100" stop="20181029024500 +0100"
title: El solista

is what I have now on my .xml

but what it should be there is the following:

TITULO "Menos cuatro y bajando"
GENERO "Cine"
CODIGO_GENERO "CN"
DURACION 100
DURACION_VISUAL 100
HORA_INICIO "00:50"
HORA_FIN "02:45"

(http://www.movistarplus.es/programacion-tv/2018-10-28/?canal=A3&v=json)

It does not matter because it will never be updated.

It is very annoying for some channels that for example are shown as Cine (Movie) and are never updated by wg.

mat8861
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 27 min

change update to f (force) in your config with i that show will be corrected tomorrow as wg update today and tomorrow with i, show is actually on 29 october

thepableras
Offline
Donator
Joined: 1 year
Last seen: 1 month
mat8861 wrote:

change update to f (force) in your config with i that show will be corrected tomorrow as wg update today and tomorrow with i, show is actually on 29 october

With force works fine. Is it impossible to use incremental and get these title updates?

mat8861
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 27 min

Sorry, i did not notice about the titlematchfactor on the ini in europe forum is set to 10, as the revision 15 i have is set already to titlematchfactor=90 and tested ok for me.

Darzlir
Offline
Donator
Joined: 1 year
Last seen: 1 week

Hi!

a couple of days ago I'm having a problem when I grab Fox:

( 20/323 ) PLUS.ES -- chan. (xmltv_id=Fox HD) -- mode Smart
iiiiiiinnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnn
Unable to update channel Fox HD
See log file for details
Exception.Message: analizando ":\s(?:Ep\.\d+)? Mimiki ke kai, ahuwale ka papa leho (Cuando el mar saca la gran ola, las rocas donde ..." - No hay suficientes ).
Exception.StackTrace: en System.Text.RegularExpressions.RegexParser.ScanRegex()
en System.Text.RegularExpressions.RegexParser.Parse(String re, RegexOptions op)
en System.Text.RegularExpressions.Regex..ctor(String pattern, RegexOptions options, TimeSpan matchTimeout, Boolean useCache)
en System.Text.RegularExpressions.Regex..ctor(String pattern, RegexOptions options)
en WGconsole.Scrub.IndicesAndRegexOperations(String element, String condition, String newstring, eType et, eMode em, Boolean logging)
en WGconsole.Scrub.IndicesAndRegexOperations(String element, String condition, String newstring, String type, String mode, Boolean debug)
en WGconsole.Scrub.Edit(String element, String[] operation, String condition)
en WGconsole.Scrub.ScrubOperations(Dictionary`2 operations, String type, Boolean channelfile, Boolean next)
en WGconsole.Scrub.ScrubShowDetails(String show, SiteIni scrubstrings)
en WGconsole.Program.UpdateChannel(String strIndex, ChannelToUpdate Chan, XmlTarget xTarget)
en WGconsole.Program.ConsoleApplication(String[] args)
Existing guide data restored!

I've also realized that for whatever reason, the team of the Spanish league "Villarreal" is not grabbed correctly and maybe it's something related with the first?

https://i.imgur.com/p2vNtaC.png

thanks!

thepableras
Offline
Donator
Joined: 1 year
Last seen: 1 month
Darzlir wrote:

Hi!
[...]
I've also realized that for whatever reason, the team of the Spanish league "Villarreal" is not grabbed correctly and maybe it's something related with the first?
https://i.imgur.com/p2vNtaC.png
thanks!

I found it several times, it is a problem of rex, the only solution (now) can be replacing Villa} by Villarreal with cron or so, until an official solution is published (new version of webgrab)

Darzlir
Offline
Donator
Joined: 1 year
Last seen: 1 week

Yep, I'm using rex to customize it to me, apparently everything is correct in other subtitles doesn't appear "}"
, except that sometimes the names are repeated, I do not know exactly why, it happens infrequently but sometimes, it happens

https://i.imgur.com/AWAHUez.png

I attach my rex config file

PS. Thx for the fix

thepableras wrote:

Darzlir wrote:
Hi!
[...]
I've also realized that for whatever reason, the team of the Spanish league "Villarreal" is not grabbed correctly and maybe it's something related with the first?
https://i.imgur.com/p2vNtaC.png
thanks!

I found it several times, it is a problem of rex, the only solution (now) can be replacing Villa} by Villarreal with cron or so, until an official solution is published (new version of webgrab)

hmmm I think I can fix it temporarily with a perl script that I use to remove certain tags depending on whether I use it for kodi or tvheadend. I will try, thx ;)

Attachments: 
Darzlir
Offline
Donator
Joined: 1 year
Last seen: 1 week

great as always blackbear199

thank you!!

Darzlir
Offline
Donator
Joined: 1 year
Last seen: 1 week

A little personal wish, what line should I modify in the plus.ini so that I can have a title like xxxx T5 E115 xxx? for now is in English "xxxx S5 E115: xxx" I just want to change the S to the T.

Thanks!

javidial
Offline
Joined: 2 months
Last seen: 2 months

Firstable, thank you so much to everybody who's making this site working. I'm new here, so I don't know much about coding.
Using this plus.es.ini and the res.config file posted here I've managed to get a xml that kodi understand. But I would love to have it in a way that plex would understand if it's a series or movie, and get the season number and the episode number.
Has anybody managed to create a guide for Plex successfully? Gracias

Darzlir
Offline
Donator
Joined: 1 year
Last seen: 1 week

@Blackbear199 thanks for the detailed explanation, it worked perfectly, only a detail based on trial and error there is an erroneous part in the add for the .ini

it's only a point instead of the comma
episode.modify {replace|Temporada |T}
episode,modify {replace|Episodio|E}

episode.modify {replace|Temporada |T}
episode.modify {replace|Episodio |E}

And work :)

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl