You are here

Need help in install

78 posts / 0 new
Last post
barry burnett
Offline
Joined: 4 months
Last seen: 3 months
Blackbear199 wrote:

have you opened your tvguide.xml file and confirmed it contains actual program data?

 

Hi yes it has a huge amount of listings with descriptions etc.

It has the one channel (BBC One HD) I am attemting to load plus lots of others.

You are referring to tvguide file in webgrab config folder right.?

Blackbear199
Offline
Joined: 2 years
Last seen: 1 day

UPDATE:

was just doing some reading on the kodi forums

#EXTM3U
#EXTINF:-1 tvg-ID="BBC One HD" tvg-name="UK:BBC 1 HD*" tvg-logo="" group-title="UK ENTERTAINMENT",UK:BBC 1 HD*

your m3u has tvg-ID= which is not the same as tvg-id=.iptv simple client will not use tvg-ID,it ignores it as its expecting it all lower case.

so this should be correct..

<channel update="i" site="uk-sky.com" site_id="2002" xmltv_id="UK:BBC One HD*">UK:BBC One HD*</channel>

Blackbear199
Offline
Joined: 2 years
Last seen: 1 day

here's the link to the kodi discussion..

https://forum.kodi.tv/showthread.php?tid=233511

the m3u list is like yours,uses tvg-ID instead of tvg-id which iptv simple client expects.

he even explains what to change using webgrab,if the above doesnt work read it plse.

 

barry burnett
Offline
Joined: 4 months
Last seen: 3 months
Blackbear199 wrote:

UPDATE:

was just doing some reading on the kodi forums

#EXTM3U
#EXTINF:-1 tvg-ID="BBC One HD" tvg-name="UK:BBC 1 HD*" tvg-logo="" group-title="UK ENTERTAINMENT",UK:BBC 1 HD*

your m3u has tvg-ID= which is not the same as tvg-id=.iptv simple client will not use tvg-ID,it ignores it as its expecting it all lower case.

so this should be correct..

<channel update="i" site="uk-sky.com" site_id="2002" xmltv_id="UK:BBC One HD*">UK:BBC One HD*</channel>

Ok i copied and pasted this line in guide.xml on desktop and epg still blank.

I wonder if I am pointing to the wrong file.?

I have tvguide.xml in config folder that has lots of channels and info guide.xml on desktop which is where epg is being pointed to.

 

Blackbear199
Offline
Joined: 2 years
Last seen: 1 day

config folder,it the file thats in the <filename>xx</filename> in your webgrab++config.xml

are you running webgrab to update the tvguide.xml file after these changes?

barry burnett
Offline
Joined: 4 months
Last seen: 3 months
Blackbear199 wrote:

config folder,it the file thats in the <filename>xx</filename> in your webgrab++config.xml

are you running webgrab to update the tvguide.xml file after these changes?

I didnt intially run webgrab after,,saw your reply and thought ok this time it will work.!!!

Its still blank.

Webgrab seems to update fine though with the series of nnnns

This is quite perplexing but fun at the same time.

Blackbear199
Offline
Joined: 2 years
Last seen: 1 day

dont know what else to tell you,all the pieces of the puzzle are in this thread.

you need to figure out what your doing wrong.

 

barry burnett
Offline
Joined: 4 months
Last seen: 3 months
Blackbear199 wrote:

dont know what else to tell you,all the pieces of the puzzle are in this thread.

you need to figure out what your doing wrong.

 

ok thnx

barry burnett
Offline
Joined: 4 months
Last seen: 3 months

Is it possible for you to view my screen.?

Blackbear199
Offline
Joined: 2 years
Last seen: 1 day

if u have teamviewer pm me details.

 

barry burnett
Offline
Joined: 4 months
Last seen: 3 months
Blackbear199 wrote:

if u have teamviewer pm me details.

 

hi did you get the details.?

barry burnett
Offline
Joined: 4 months
Last seen: 3 months
barry burnett wrote:

Blackbear199 wrote:

if u have teamviewer pm me details.

 

hi did you get the details.?

lol..that was very cool..you re a star Blackbear.

So the issue was just the names not matching..ok.

Blackbear199
Offline
Joined: 2 years
Last seen: 1 day

ya,one little typo and it dont work.

i didnt mean to close kodi(with the close button),it may not have saved ur iptv simple client setting as i didnt close it via the exit menu.

so check them and set them again if they are not correct.

so when u switch back to the m3u url it will be the same,tvg-name in both places on all ur <channel lines in webgrab++config.xml.ignore the tvg-ID name as its not used.

 

barry burnett
Offline
Joined: 4 months
Last seen: 3 months
Blackbear199 wrote:

ya,one little typo and it dont work.

i didnt mean to close kodi(with the close button),it may not have saved ur iptv simple client setting as i didnt close it via the exit menu.

so check them and set them again if they are not correct.

so when u switch back to the m3u url it will be the same,tvg-name in both places on all ur <channel lines in webgrab++config.xml.ignore the tvg-ID name as its not used.

 

its ok as I have changed the path back to the original url.

So the basic principle is the name on the guide.xml has to be the same as the one in m3u list and not (necessarily) the name on the guide.?

Is there some kind of auto match software to do this.?

Blackbear199
Offline
Joined: 2 years
Last seen: 1 day

bacically yes.

has to be done by had.(unless u want to try to write something to do it).

the names that are preset on the <channel lines are not in any special format.they come from the actual site(name they use for the channel) and differ from site to site.

FYI webgrab usually only needs the site_id from the <channel line to identify a channel  on a site but sometimes the xmltv_id is also used.

there are only a few sites that do this(i dont even remember which ones as they are rare) so usually i recommend only changing the display name(the name between >xxxxx<) but for your case its fine to change both as i know only the site_id is used by webgrab for this site.

 

barry burnett
Offline
Joined: 4 months
Last seen: 3 months
Blackbear199 wrote:

bacically yes.

has to be done by had.(unless u want to try to write something to do it).

the names that are preset on the <channel lines are not in any special format.they come from the actual site(name they use for the channel) and differ from site to site.

FYI webgrab usually only needs the site_id from the <channel line to identify a channel  on a site but sometimes the xmltv_id is also used.

there are only a few sites that do this(i dont even remember which ones as they are rare) so usually i recommend only changing the display name(the name between >xxxxx<) but for your case its fine to change both as i know only the site_id is used by webgrab for this site.

 

yes Blackbear,

if I could code I would certainly do what I could for this community as its great..

I do use data matching software but its for numbers..

Maybe this can be altered in some way. I will ask the person who wrote it.

Blackbear199
Offline
Joined: 2 years
Last seen: 1 day

well i dont think its practical,how is one going to match the name in the m3u to the name in the channels.xml file?

BBC One HD and BBC 1 HD is a perfect comparision,we both know its the same channel but how do you tell a script this? or are u going to include artifical intelligence?

kidding.lol

 

barry burnett
Offline
Joined: 4 months
Last seen: 3 months
Blackbear199 wrote:

well i dont think its practical,how is one going to match the name in the m3u to the name in the channels.xml file?

BBC One HD and BBC 1 HD is a perfect comparision,we both know its the same channel but how do you tell a script this? or are u going to include artifical intelligence?

kidding.lol

 

Hi again,

is there a way to automatically know what the correct spelling should be.?

A few of my entries are perfectly matched (copy/pasted) to my m3u list but still doesnt polulate in epg.

Also, is there a way to tell if the grab site is defunct.?

Blackbear199
Offline
Joined: 2 years
Last seen: 1 day

thats the problem,the spelling can be anything one wants it to be as long as its the same in the m3u and the <channel Line.

to know if a channel has epg u either need to check your guide.xml file or look in your webgrab++log.txt file.

if u see "no index page recieced" or "no programs in showsplit" or pretty much any other error then more than likely the channel has no epg data or there is something else wrong.

what i usually do is goto the website with my browser and see if each channel i add actually has epg data.this happens all the time that a channel may be listed in the channels.xml file but the website doesnt have any epg data for it.its just the way it is,remember your webscrapping epg data.its not a dedicated website like gracenote,ect that its sole purpose is to povide epg data.

if thats what you want then sign up,make sure u have lots in the bank as it aint going to be cheap.

 

barry burnett
Offline
Joined: 4 months
Last seen: 3 months
Blackbear199 wrote:

thats the problem,the spelling can be anything one wants it to be as long as its the same in the m3u and the <channel Line.

to know if a channel has epg u either need to check your guide.xml file or look in your webgrab++log.txt file.

if u see "no index page recieced" or "no programs in showsplit" or pretty much any other error then more than likely the channel has no epg data or there is something else wrong.

what i usually do is goto the website with my browser and see if each channel i add actually has epg data.this happens all the time that a channel may be listed in the channels.xml file but the website doesnt have any epg data for it.its just the way it is,remember your webscrapping epg data.its not a dedicated website like gracenote,ect that its sole purpose is to povide epg data.

if thats what you want then sign up,make sure u have lots in the bank as it aint going to be cheap.

 

oK,

my head is spinning now lol.

my epg info from yesterday has disappeared.I dont think I changed anything.

I have seen other xml epg files that seem to be in slightly different format.

Would these need to work with other pvr clients.?

eg. I got an peg (same source as m3u) but format seems slightly different I guess this can be amended to work the way my guide.xml works.?

Blackbear199
Offline
Joined: 2 years
Last seen: 1 day

if u have epg from the same source as ur m3u it shud work without any modifications.

its its in xml format? paste a sample <programme....</programme> for a single show.

 

barry burnett
Offline
Joined: 4 months
Last seen: 3 months
Blackbear199 wrote:

if u have epg from the same source as ur m3u it shud work without any modifications.

its its in xml format? paste a sample <programme....</programme> for a single show.

 

can I pm you the file to see.?

it doesnt seem to have the same header eg

 <?xml version="1.0"?>
<settings>
<filename>C:\Users\pc\AppData\Local\\WebGrab+Plus\guide.xml</filename>
<mode>m</mode>
<postprocess grab="y" run="n">mdb </postprocess>
<proxy>automatic</proxy>
<user-agent>Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; yie9)</user-agent>
<logging>off</logging>
<retry time-out="5">5</retry>
<skip>noskip</skip>
<timespan>1</timespan>
<update>f</update>

 

 

this is thefirst line in the file

<?xml version="1.0" encoding="UTF-8"?>
<tv generator-info-name="WebGrab+Plus/w MDB &amp; REX Postprocess -- version  V2.0 -- Jan van Straaten" generator-in

Blackbear199
Offline
Joined: 2 years
Last seen: 1 day

thats ur webgrab++config.xml file

it has nothing to do with epg data.

do u download the file locally or it it a url(iptv simple client can do both)

open ur guide.xml that webgrab creates(C:\Users\pc\AppData\Local\\WebGrab+Plus\guide.xml)

it should look similar to this.

also

<?xml version="1.0" encoding="UTF-8"?>
<tv generator-info-name="WebGrab+Plus/w MDB &amp; REX Postprocess -- version  V2.0 -- Jan van Straaten" generator-in

doesnt mean anything,its just a note on what created the file

barry burnett
Offline
Joined: 4 months
Last seen: 3 months
Blackbear199 wrote:

thats ur webgrab++config.xml file

it has nothing to do with epg data.

do u download the file locally or it it a url(iptv simple client can do both)

open ur guide.xml that webgrab creates(C:\Users\pc\AppData\Local\\WebGrab+Plus\guide.xml)

it should look similar to this.

also

<?xml version="1.0" encoding="UTF-8"?>
<tv generator-info-name="WebGrab+Plus/w MDB &amp; REX Postprocess -- version  V2.0 -- Jan van Straaten" generator-in

doesnt mean anything,its just a note on what created the file

<?xml version="1.0" encoding="UTF-8"?>
<tv generator-info-name="WebGrab+Plus/w MDB &amp; REX Postprocess -- version  V2.0 -- Jan van Straaten" generator-info-url="http://www.webgrabplus.com">
  <channel id="BBC One Lon">
    <display-name lang="en">BBC One Lon</display-name>
    <icon src="http://d57e32cb.static.ziggozakelijk.nl/%3Ca%20href%3D"http://tv.sky.com/logo/248/60/skychb2002.png">http://tv.sky.com/logo/248/60/skychb2002.png" />
    <url>http://www.tv.sky.com</url>
  </channel>
  <channel id="BBC Two Eng">
    <display-name lang="en">BBC Two Eng</display-name>
    <icon src="http://d57e32cb.static.ziggozakelijk.nl/%3Ca%20href%3D"http://tv.sky.com/logo/248/60/skychb2006.png">http://tv.sky.com/logo/248/60/skychb2006.png" />
    <url>http://www.tv.sky.com</url>
  </channel>
  <channel id="BBC 3">
    <display-name lang="en">BBC 3</display-name>
    <url>http://www.theguardian.com</url>
  </channel>
  <channel id="ITV">
    <display-name lang="en">ITV</display-name>
    <icon src="http://d57e32cb.static.ziggozakelijk.nl/%3Ca%20href%3D"http://tv.sky.com/logo/248/60/skychb6000.png">http://tv.sky.com/logo/248/60/skychb6000.png" />
    <url>http://www.tv.sky.com</url>
  </channel>
  <channel id="Channel 4">
    <display-name lang="en">Channel 4</display-name>
    <icon src="http://d57e32cb.static.ziggozakelijk.nl/%3Ca%20href%3D"http://tv.sky.com/logo/248/60/skychb1621.png">http://tv.sky.com/logo/248/60/skychb1621.png" />
    <url>http://www.tv.sky.com</url>
  </channel>
  <channel id="Channel 5">
    <display-name lang="en">Channel 5</display-name>
    <icon src="http://d57e32cb.static.ziggozakelijk.nl/%3Ca%20href%3D"http://tv.sky.com/logo/248/60/skychb1800.png">http://tv.sky.com/logo/248/60/skychb1800.png" />
    <url>http://www.tv.sky.com</url>
  </channel>
  <channel id="Sky1">
  

this is more of the file..

I guess it uses url .

Thing is, this is the first thing I tried in simple client . It was set to internet and not local and it didnt work.

Any suggestions on this approach.

Yes I agree should be more simple as is from the same source.

 

Blackbear199
Offline
Joined: 2 years
Last seen: 1 day

this is you webgrab xml file,what does the one your m3u provider link look like?

try the link in your web browser.

 

barry burnett
Offline
Joined: 4 months
Last seen: 3 months
Blackbear199 wrote:

this is you webgrab xml file,what does the one your m3u provider link look like?

try the link in your web browser.

 

sent you pm

barry burnett
Offline
Joined: 4 months
Last seen: 3 months

Another question Blackbear,

in the guide and m3u files , there are numerous BBC one channels for example.

Is there a way to know which are relevant to each other, or does it matter.?

Pages

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl