You are here

Licensed as an un_registered_user

9 posts / 0 new
Last post
SergeantPanda
Offline
Donator
Joined: 3 months
Last seen: 2 months
Licensed as an un_registered_user

I am having issues getting listed as a registered user (I have actually donated but I understand that takes time).

For some reason, I keep getting the license for an unregistered user. I believe I have the license line exactly as it is supposed to be and I have also ran it several times with the force option.

Here is my license config line:

<license wg-username="SergeantPanda" registered-email="myemail@gmail.com" password="mypwfromprofile">f</license>

I then get this in the WGLicense.log.txt file:

[ Info ] License request/update
[ Info ] Username 'SergeantPanda'
[Warning ] A previous record dd 2022/10/22 for un_registered user 'SergeantPanda' found
[Warning ] Correct the username in the license request :
[ Info ] <license wg-username="SergeantPanda" registered-email="myemail@gmail.com" password="mypwfromprofile" />
[Warning ] License has expired !
[ Info ] The program will run with performance settings : 'un_registered_user'
[ Info ] License check .. done

Anyone have any ideas on why I am not at least showing up as a registered user? Does it take several hours (my account is only a couple hours old)

Thanks!

SergeantPanda
Offline
Donator
Joined: 3 months
Last seen: 2 months

I'm going to go ahead and leave this up for others that may have the same problem as me in the future but I did get this to work as expected.

The problem ended up being that I am using a docker container for WebGrab++ (https://hub.docker.com/r/linuxserver/webgrabplus) and I had not added the HOSTNAME and MAC_ADDRESS fields that it requires.

thonda
Offline
Joined: 2 months
Last seen: 2 months

Having the same issue here.
I just created new account but still getting a license as unregistered user:

[ ] WebGrab++ license request and update log
[ ] 2022/11/07 12:03
[ ]
[ Info ] License request/update
[ Info ] Username 'thonda'
[Warning ] A previous record dd 2022/11/07 for un_registered user 'thonda' found
[Warning ] Correct the username in the license request :
[ Info ]
[Warning ] License has expired !
[ Info ] The program will run with performance settings : 'un_registered_user'
[ Info ] License check .. done
[ ]

Any thoughts?
I'm running it on Raspbian GNU/Linux 10 (buster)

SergeantPanda
Offline
Donator
Joined: 3 months
Last seen: 2 months

I suspect that there is a significant delay from the time you join the website and the time it recognizes your account for a license. I would try again but this time make sure there is an "f" inside the license field in the xml config file.

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 1 day

@thonda paypal update every 3-4 hours their api, then is processed by webgrab, when you see the piggy icon, you should be able to run it. Sorry but it's the time paypal takes.

SergeantPanda
Offline
Donator
Joined: 3 months
Last seen: 2 months

I think that is where the confusion comes in from newer users (this is what happened to me). They aren't even waiting for donor status which is made clear in multiple places on the site that it takes time. The problem they have that will make you keep second guessing your config is it shows up as an unregistered user which you would assume would be a non issue.

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 1 day

@thonda should have at least "registred user" have you tried to run force update of license ?

thonda
Offline
Joined: 2 months
Last seen: 2 months

Yes, thanks a lot guys.
Seems there is some delay before the account is fully provisioned.
I am now able to log in and my license now shows as "registered_user". So all is good now. It just needed some time :)

mat8861
Offline
WG++ Team memberDonator
Joined: 7 years
Last seen: 1 day

Just for your info you can have fully enabled functions, with a small donation.Have a look to your wglicense.log and the donation page for more info.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl