You are here

Bug? WG.common.xmltv.Title

20 posts / 0 new
Last post
Netuddki
Offline
Joined: 3 years
Last seen: 5 months
Bug? WG.common.xmltv.Title

I get this now sometimes with different inis (using latest beta):

 MISSING show added,
      show with ---- start = 07/10/2017 05:00:00 stop = 07/10/2017 05:00:00 title = WG.common.xmltv.Title
      Added before - start = 07/10/2017 05:00:00 stop = 08/10/2017 00:00:00 title = TRT Çocuk programlaması

Netuddki
Offline
Joined: 3 years
Last seen: 5 months

Thanks

wbmk
Offline
Joined: 3 years
Last seen: 1 year

Is there a ETA when this fix wil be published?

Thanx, WBMK

kroken
Offline
Donator
Joined: 2 years
Last seen: 17 hours

Getting the same with horizon now, dunno if its webgrab or the ini but hope it will be fixed soon.

mat8861
Offline
WG++ Team memberDonator
Joined: 3 years
Last seen: 1 hour

Any other new function ? Can't wait to see the new version.

kroken
Offline
Donator
Joined: 2 years
Last seen: 17 hours

Takes forever to grab now.. i get this too on serveral ini. any eta??

chriskeens
Offline
Joined: 10 months
Last seen: 6 months

Any news on a release to fix this?

doglover
Offline
Donator
Joined: 6 years
Last seen: 19 hours

This error is really annoying, as it prolongs dramatically the time to grab.

Is there anything we can do to the SiteIni, to avoid it?
Or can a bugfix be released soon pls.

Willy

kroken
Offline
Donator
Joined: 2 years
Last seen: 17 hours

Couldnt agree more, we need fix. blackbear and others already have this but not sharing

kroken
Offline
Donator
Joined: 2 years
Last seen: 17 hours

I actually tried contacting but without any luck. and of course I don't expect you to share the software here without their approval lol but at least your one of the team and could have some influence on this, right? I mean it's like a year since update or what? Is there any roadmap or something or is this project dead?

jksmurf
Offline
jksmurf's picture
Joined: 6 years
Last seen: 3 weeks

+1 here I get this WG.common.xmltv.Title replacement also

[CODE]
Info ] epg correction :
[ Info ] CHANGED show corrected,
[ Info ] show with ---- start = 28/02/2019 00:30:00 stop = 28/02/2019 01:00:00 title = WG.common.xmltv.Title
[ Info ] Replaces ----- start = 28/02/2019 00:30:00 stop = 28/02/2019 01:00:00 title = Inside Story E58
[ Debug ] suspicious title in index page
[ Debug ] Can't match any (sub)detail title(s) with any index title(s):
[ Debug ] index title(s):
[ Debug ] "The Stream"
[ Debug ] (sub)detail title(s):
[ Debug ] "The Stream E34"
[ Info ] epg correction :
[ Info ] CHANGED show corrected,
[ Info ] show with ---- start = 28/02/2019 04:30:00 stop = 28/02/2019 05:00:00 title = WG.common.xmltv.Title
[ Info ] Replaces ----- start = 28/02/2019 04:30:00 stop = 28/02/2019 05:00:00 title = The Stream E34
[ Debug ] suspicious title in index page
[ Debug ] Can't match any (sub)detail title(s) with any index title(s):
[ Debug ] index title(s):[/CODE]

Goran
Offline
Joined: 1 year
Last seen: 58 min

index title
"The Stream"
not matching with show title
"The Stream E34"

it's not replacement
different scrub data in index_title and title (additional " E34")

jksmurf
Offline
jksmurf's picture
Joined: 6 years
Last seen: 3 weeks

Thank you but if I run it again I get the same thing?
Surely the previous one would now match the new one?

Blackbear199
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

u dont undertand how wg title comparison works.
when u run is the first time..

[ Debug ] index title(s):
[ Debug ] "The Stream"
[ Debug ] (sub)detail title(s):
[ Debug ] "The Stream E34"

the title written to you guide.xml is "The Stream E34".
this is because the details title ALWAYS overwrites the index title when it exists.
from the manual..
The show title is found on two places in most sites, on the index page and on the show detail page. The latter is
the most accurate and is used by WebGrab+Plus for the xmltv element - title– .

so when u run it again(do a update) this is what happens.
rather than scrub the index_tile and details title and compare them,wg determines first if a update is needed.

wg scrubs the index_title only from page data "The Stream" and compares it to guide.xml title "The Stream E34" and it thinks these titles dont match so a update is triggered.

so once again ur back to ur original first run scenario as the title in guide.xml no longer matters once a update is triggered and the index_title and details title are scrubbed and compared and this will repeat until the show is gone(becomes a show from yesterday).

now the above is if you do a incrimental update,using force doesnt check it scrubs everything anyway.

jksmurf
Offline
jksmurf's picture
Joined: 6 years
Last seen: 3 weeks

Thanks Blackbear that’s a fantastic explanation, thanks for taking the time, much appreciated.

Blackbear199
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

glad u were amused.
if u understood what i said is another story...

jksmurf
Offline
jksmurf's picture
Joined: 6 years
Last seen: 3 weeks
jksmurf wrote:

Thanks Blackbear that’s a fantastic explanation, thanks for taking the time, much appreciated.

Re-reading the explanation though, couldn't WG be set up so when the checks for changes are performed, A is compared to A and B to B, where A = title and B =subtitle, rather than A being compared to B. As you point out, details will always be taken over title, but then when you go back each time and compare it, they will never match.

k.

Blackbear199
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

yes..
look on ur site {xx} line for..
titlematchfactor=xx
this sets how much the index title and details title can differ.
default is 90
or 90% where 100 wud be a exact match.dont ask how this is calculated as i dont know as it done internally by webrab.
u can change it to whatever u wish
0 disables the title check.

jksmurf
Offline
jksmurf's picture
Joined: 6 years
Last seen: 3 weeks

Cheers Blackbear199,

Interesting functionality, not sure I'm too fussed about it, would just make the log shorter without all the (apparent) changes. My guess is reducing it to 70 or 80 might not pick up real changes. I will watch it for now ta; I do need to remove the EXX suffixes that are produced in the Details e.g. SHOW E62 vs just SHOW (from Title), but I will use Regex (hopefully) for that.

Blackbear199
Offline
Donator
Joined: 3 years
Last seen: 3 weeks

wg 2.1.9 beta was released yesterday that has this fixed,see the change log for full list of changes.

Log in or register to post comments

Brought to you by Jan van Straaten

Program Development - Jan van Straaten ------- Web design - Francis De Paemeleere
Supported by: servercare.nl